[webkit-reviews] review denied: [Bug 13707] REGRESSION: JavaScript exceptions on quotes.burntelectrons.org : [Attachment 14611] proposed fix

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue May 22 19:34:03 PDT 2007

Darin Adler <darin at apple.com> has denied Alexey Proskuryakov <ap at webkit.org>'s
request for review:
Bug 13707: REGRESSION: JavaScript exceptions on quotes.burntelectrons.org

Attachment 14611: proposed fix

------- Additional Comments from Darin Adler <darin at apple.com>
Document::setBody should take a PassRefPtr<HTMLElement> rather than an

Why not have getElementsByName return NameNodeList? Does it create a real
problem. I ask because sometimes we can generate more efficient code if the
specific class is known to the caller, so sometimes we might want our internal
function to have a more-specific type than what's exported to JS and other
public API.

+	 (WebCore::Frame::documentLoader): Encapsulated
"frame->loader()->documentLoader()" idiom,
+	 which is dangerous because that could be the loader for the previous
or next document in this
+	 frame rather than the current one. Having it in one place will make
fixing it easier.

I agree with your point about encapsulating it in one place. But that place
should be in Document, not Frame!

More information about the webkit-reviews mailing list