[webkit-reviews] review denied: [Bug 14060] [CAIRO] SVG support : [Attachment 15001] Cairo SVG support

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jun 13 10:17:44 PDT 2007


Rob Buis <rwlbuis at gmail.com> has denied Alp Toker <alp at atoker.com>'s request
for review:
Bug 14060: [CAIRO] SVG support
http://bugs.webkit.org/show_bug.cgi?id=14060

Attachment 15001: Cairo SVG support
http://bugs.webkit.org/attachment.cgi?id=15001&action=edit

------- Additional Comments from Rob Buis <rwlbuis at gmail.com>

>+
>+	  if (boundingBoxMode()) {
>+	      // TODO: use RenderPathCairo's strokeBBox?
>+	      double x1, y1, x2, y2;
>+	      cairo_fill_extents(cr, &x1, &y1, &x2, &y2);
>+	      cairo_matrix_translate(&matrix, x1, y1);
>+	      cairo_matrix_scale(&matrix, x2 - x1, y2 - y1);
>+	      cairo_matrix_multiply(&matrix, &matrix, &gradient_matrix);
>+	      cairo_matrix_invert(&matrix);
>+	  {
>+	  double x0, x1, y0, y1;
>+	      x0 = linear->gradientStart().x();
>+	      y0 = linear->gradientStart().y();
>+	      x1 = linear->gradientEnd().x();
>+	      y1 = linear->gradientEnd().y();
>+	      pattern = cairo_pattern_create_linear(x0, y0, x1, y1);
>+	  }
>+	  } else return false;

I can't tell what is going on there, do you mean a if/ilse? If it is an
anonymous block, that is hard to read, please rewrite so it doesnt have one.

>+	  delete dsh;

Should use delete[].


>+	  if(path.isEmpty())
>+    if(!surface)

Style issues.

So all issues need fixing.
Cheers,

Rob.



More information about the webkit-reviews mailing list