[webkit-reviews] review granted: [Bug 14757] REGRESSION: HTMLTokenizer::processingData implementation is incorrect : [Attachment 15763] Final patch with tweak I suggested to previous patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jul 31 13:16:43 PDT 2007


Darin Adler <darin at apple.com> has granted Brady Eidson <beidson at apple.com>'s
request for review:
Bug 14757: REGRESSION: HTMLTokenizer::processingData implementation is
incorrect
http://bugs.webkit.org/show_bug.cgi?id=14757

Attachment 15763: Final patch with tweak I suggested to previous patch
http://bugs.webkit.org/attachment.cgi?id=15763&action=edit

------- Additional Comments from Darin Adler <darin at apple.com>
+    if (m_frame->page())
+	 checkLoadComplete();

The checkLoadComplete() function checks to see if the page is 0 -- why do we
need an additional check in the caller? Is the problem with the assertion? If
so, maybe we should move the assertion inside the if statement.

+    if (m_frame->page()) {
+	 if (asynchronous)
+	     scheduleCheckLoadComplete();
+	 else
+	     checkLoadComplete();
+    }

Also seems unnecessary to check for page of 0 here.

I don't understand the meaning of the "asynchronous" parameter in
stopForUserCancel. The stop itself seems to be immediate no matter what, so the
only that's deferred is the "check load complete". Given that, I think the
parameter name is quite unclear.

Otherwise looks, good, and these are really nitpicks, so r=me.



More information about the webkit-reviews mailing list