[webkit-reviews] review denied: [Bug 12566] [Drosera] Console history fixups : [Attachment 12911] History fixes

bugzilla-request-daemon at macosforge.org bugzilla-request-daemon at macosforge.org
Sun Feb 4 18:17:14 PST 2007

Darin Adler <darin at apple.com> has denied Darin Adler <darin at apple.com>'s
request for review:
Bug 12566: [Drosera] Console history fixups

Attachment 12911: History fixes

------- Additional Comments from Darin Adler <darin at apple.com>
Seems to me we should be looking at keypress events, not keydown or keyup,
since it's keypress events that actually change the contents of an input
element. To process after the key is hit, we could perhaps listen for the input
element's "change" event and keep a global variable to indicate what keypress
is being processed.

+    if(event.keyCode != 38 && event.keyCode != 40 && event.keyCode != 13) {

We put spaces between if and ( characters.

+    historyDisplay.scrollTop = history.scrollHeight;

This looks wrong to me. I think you want historyDisplay.scrollHeight here.

review- just because of the scrollHeight mistake.

More information about the webkit-reviews mailing list