[webkit-reviews] review granted: [Bug 16464] Modify WebCore to use win32 thread primitives : [Attachment 17965] Updated based on review.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Dec 17 10:24:33 PST 2007

Darin Adler <darin at apple.com> has granted Brent Fulgham <bfulgham at gmail.com>'s
request for review:
Bug 16464: Modify WebCore to use win32 thread primitives

Attachment 17965: Updated based on review.

------- Additional Comments from Darin Adler <darin at apple.com>
 71 static const long MaxSemaphoreCount = static_cast<long>((~0u) >> 1);

I think it needs to be ~0UL rather than ~0U. And also there is no need for
parentheses there -- the precedence of the ~ operator is tighter than the >>
operator, and I think it's easier to read as is.

Patch has some tabs in it. We can't check in patches with tabs.

 115	 unsigned was_gone=0;

Unused local variable here.

Otherwise looks good. r=me, although I'm a little nervous about the level of
testing that will be required to vet this on Windows with Safari.

More information about the webkit-reviews mailing list