[webkit-reviews] review granted: [Bug 11117] WebDataSource data should be moved to WebDocumentLoadState : [Attachment 10864] patch

bugzilla-request-daemon at macosforge.org bugzilla-request-daemon at macosforge.org
Mon Oct 2 08:32:15 PDT 2006


Darin Adler <darin at apple.com> has granted Darin Adler <darin at apple.com>'s
request for review:
Bug 11117: WebDataSource data should be moved to WebDocumentLoadState
http://bugs.webkit.org/show_bug.cgi?id=11117

Attachment 10864: patch
http://bugs.webkit.org/attachment.cgi?id=10864&action=edit

------- Additional Comments from Darin Adler <darin at apple.com>
+- (void)setResponse:(NSURLResponse *)resp
+{
+    [response release];
+    response = [resp retain];
+}

Shouldn't we use the retain before release idiom here, or add an assert?

+    // XXX: fixme retains

I think we should replace this comment with a more-coherent one or remove it.

-    ASSERT(!loading);
+    ASSERT(![loadState isLoading]);

Maybe that assert should move into the loadState object?

r=me



More information about the webkit-reviews mailing list