[webkit-reviews] review denied: [Bug 6755] CSS3: Borders rounded with border-radius don't draw the roundings : [Attachment 8487] Fixed first shot at border-radius (still incomplete)

bugzilla-request-daemon at opendarwin.org bugzilla-request-daemon at opendarwin.org
Tue May 23 13:04:07 PDT 2006


Eric Seidel <macdome at opendarwin.org> has denied Eric Seidel
<macdome at opendarwin.org>'s request for review:
Bug 6755: CSS3: Borders rounded with border-radius don't draw the roundings
http://bugzilla.opendarwin.org/show_bug.cgi?id=6755

Attachment 8487: Fixed first shot at border-radius (still incomplete)
http://bugzilla.opendarwin.org/attachment.cgi?id=8487&action=edit

------- Additional Comments from Eric Seidel <macdome at opendarwin.org>
I think this needs some cleanup.
drawArc shoudl have lables on all of its "int" parameters in the header.  The
general rule is that we omit parameter names when they don't add to readabilty
of the code (for example ExecState* exec), but we keep them when they do.  In
this case, these definitely need lables.

That said, drawArc should also be converted to use the more modern IntRect or
possibly FloatRect.  If you do convert to IntRect, you might want to have local
float x; float y; float w, etc. variables since pretty much all uses of x, y,
w, h, you're casting directly to floats.

int a and int alen need better names.

Note that you should probalby also look at the cairo implementation of drawArc
and see what code can/should be shared.

render_l, render_r render_radii , ignore_left, ignore_right, don't obey modern
style guidelines.

We can talk more in person.



More information about the webkit-reviews mailing list