[webkit-reviews] review denied: [Bug 8910] Various code cleanups in RenderBox : [Attachment 8312] patch

bugzilla-request-daemon at opendarwin.org bugzilla-request-daemon at opendarwin.org
Sun May 14 20:23:41 PDT 2006

Darin Adler <darin at apple.com> has denied Darin Adler <darin at apple.com>'s
request for review:
Bug 8910: Various code cleanups in RenderBox

Attachment 8312: patch

------- Additional Comments from Darin Adler <darin at apple.com>
I'm not fond of adding parentheses around the equality comparisons in if
statements. I don't like formatting where a continued if condition has the same
indenting level as the code that will execute if the if is true. I typically
indent the if condition an extra level to avoid this.

In headers, I like leaving out the parameter name if it's completely redundant
with the type, so all those "WidthType widthType" should just be "WidthType".

+	     int maxW =  calcWidthUsing(MaxWidth, containerWidth);

Two spaces here after the = sign, should just be one.

I don't understand why we'd set m_marginLeft and m_marginRight to 0 just before
setting them inside the width.isAuto() case. Can those lines go inside the

The changes look good otherwise. I like the continued cleanup of
calcWidthUsing. I'm tempted to say review+, but since this is all about style I
think I'll say review- for the m_marginLeft/Right thing if for nowthing else.

More information about the webkit-reviews mailing list