[webkit-reviews] review granted: [Bug 7824] Push parts of form submission code down into Frame.cpp : [Attachment 7145] push parts of MacFrame into Frame, GraphicsContextMac into GraphicsContext

bugzilla-request-daemon at opendarwin.org bugzilla-request-daemon at opendarwin.org
Sat Mar 18 04:32:17 PST 2006


Darin Adler <darin at apple.com> has granted Darin Adler <darin at apple.com>'s
request for review:
Bug 7824: Push parts of form submission code down into Frame.cpp
http://bugzilla.opendarwin.org/show_bug.cgi?id=7824

Attachment 7145: push parts of MacFrame into Frame, GraphicsContextMac into
GraphicsContext
http://bugzilla.opendarwin.org/attachment.cgi?id=7145&action=edit

------- Additional Comments from Darin Adler <darin at apple.com>
I'd think you could just rename drawFloatImage to drawImage.

+    ~GraphicsContextPrivate();

Seems unnnecessary. The default destructor will do the job.

+    int width = ((s == BSTop || s == BSBottom) ? y2 - y1 : x2 - x1 );

Space before that last parenthesis looks strange to me. Maybe remove the outer
parentheses altogether?

Adding these values directly to Frame rather than to FramePrivate seems like it
might be moving in the wrong direction. Not sure. Are we planning to get rid of
FramePrivate?

I think recordFormValue should take a PassRefPtr rather than a raw pointer.

Seems OK to land as-is. r=me



More information about the webkit-reviews mailing list