[webkit-reviews] review granted: [Bug 9688] Fix up value conversions in JS API : [Attachment 9154] patch including exception handling

bugzilla-request-daemon at opendarwin.org bugzilla-request-daemon at opendarwin.org
Mon Jul 3 18:24:46 PDT 2006


Darin Adler <darin at apple.com> has granted Darin Adler <darin at apple.com>'s
request for review:
Bug 9688: Fix up value conversions in JS API
http://bugzilla.opendarwin.org/show_bug.cgi?id=9688

Attachment 9154: patch including exception handling
http://bugzilla.opendarwin.org/attachment.cgi?id=9154&action=edit

------- Additional Comments from Darin Adler <darin at apple.com>
+    if (completion.complType() == Throw) {
+	 if (exception)
+	     *exception = completion.value();
+	 return NULL;
+    } else if (completion.value())
+	 return toRef(completion.value());
+    else // happens, for example, when the only statement is an empty (';')
statement
+	 return toRef(jsUndefined());

I find it more readable to omit the else after return in cases like this.

r=me



More information about the webkit-reviews mailing list