[webkit-reviews] review granted: [Bug 6878] Clean up CachedImage : [Attachment 6027] Better!

bugzilla-request-daemon at opendarwin.org bugzilla-request-daemon at opendarwin.org
Fri Jan 27 14:22:00 PST 2006

Darin Adler <darin at apple.com> has granted Dave Hyatt <hyatt at apple.com>'s
request for review:
Bug 6878: Clean up CachedImage

Attachment 6027: Better!

------- Additional Comments from Darin Adler <darin at apple.com>
Can we change validRect to be a IntSize instead of an IntRect? After all, the
image does load from the top down. In fact, maybe validRect should be
validHeight instead and just be an integer, since it really can only indicate
how many complete rows are valid.

m_image->validRect().isValid() in particular will collide with my coming patch
that removes "isValid()" entirely from IntRect. And I'm definitely getting rid
of a distinction between null and empty for rects, so isNull is especially bad.
I just think that m_image->validHeight() and checking that against 0 would be
so much clearer for almost every case.

And maybe there's a word that's clearer than "valid" for "what's loaded so

What happened to the isTransparent() optimization? Do we just optimize that
case elsewhere now?

Looks nice overall. r=me

More information about the webkit-reviews mailing list