[webkit-reviews] review granted: [Bug 6705] use PassRefPtr in more of the basic DOM operations : [Attachment 5824] less raw pointer, more PassRefPtr

bugzilla-request-daemon at opendarwin.org bugzilla-request-daemon at opendarwin.org
Sun Jan 22 04:54:35 PST 2006

Anders Carlsson <andersca at mac.com> has granted Darin Adler <darin at apple.com>'s
request for review:
Bug 6705: use PassRefPtr in more of the basic DOM operations

Attachment 5824: less raw pointer, more PassRefPtr

------- Additional Comments from Anders Carlsson <andersca at mac.com>
Looks good, just a few stylistic comments:

* In ContainerNodeImpl::insertBefore:

-	     newParent->removeChild( child, exceptioncode );
-	 if (exceptioncode)
+	     newParent->removeChild( child, ec );
+	 if (ec)

the spacing should be fixed in the call to removeChild


+    if (next) next->setPreviousSibling(prev);
+    if (prev) prev->setNextSibling(next);
+    if (m_firstChild == child) m_firstChild = next;
+    if (m_lastChild == child) m_lastChild = prev;

the statements should be on a separate line from the expressions, like in

* HTMLOptGroupElementImpl::insertBefore: 

the spacing in the function call declaration should be fixed

More information about the webkit-reviews mailing list