[webkit-reviews] review denied: [Bug 6642] Split XMLHttpRequest class into JS binding and implementation : [Attachment 5760] revised patch

bugzilla-request-daemon at opendarwin.org bugzilla-request-daemon at opendarwin.org
Thu Jan 19 10:49:42 PST 2006

Darin Adler <darin at apple.com> has denied Alexey Proskuryakov <ap at nypop.com>'s
request for review:
Bug 6642: Split XMLHttpRequest class into JS binding and implementation

Attachment 5760: revised patch

------- Additional Comments from Darin Adler <darin at apple.com>
Not sure I like the "JS" naming here, since it's novel and doesn't match the
rest of the ecma directory. But perhaps it's forward looking and all of this is
temporary since we hope to auto-generate the files.

We need to eliminate that gcProtect/Unprotect as you suggested.

All the places that say DOM:: should be WebCore:: instead.

I really dislike the special case for undefiined. So if you want to be
conservative and use the behavior, how about making a jsStringOrUndefined
alongside jsStringOrNull? When we autogenerate headers we're going to need
syntax to say whether a 0 should change to a null or an undefined or an empty
string, which is annoying. I'm hoping we won't ever need the undefined case.

More information about the webkit-reviews mailing list