[webkit-reviews] review granted: [Bug 10467] WebKit should have Qt platform support (Part II) : [Attachment 10155] Patch chunk: canvas/frame related stuff

bugzilla-request-daemon at opendarwin.org bugzilla-request-daemon at opendarwin.org
Thu Aug 24 06:48:23 PDT 2006

Anders Carlsson <andersca at mac.com> has granted Anders Carlsson
<andersca at mac.com>'s request for review:
Bug 10467: WebKit should have Qt platform support (Part II)

Attachment 10155: Patch chunk: canvas/frame related stuff

------- Additional Comments from Anders Carlsson <andersca at mac.com>
Just two comments:

1) There should not be a page object for every frame, all frames on a web page
should share the page object.

2) In FrameQt.h, there are two functions at the bottom called "Win". These are
used to cast easily between Frame and the Frame subclass (which is FrameQt in
this case). This function should be renamed to Qt (or something like that).
Win() is used for the windows port and we have Mac() for the mac port.

I've discussed #1 with Nikolas Zimmermann and he will fix this when the Unity
KPart is written. 

Regarding #2. I see that the Win() casting function isn't used anywhere (it
could be in some places, such as ScrollViewCanvasQt::handleKeyEvent) so you
could either remove it or rename it and start using it.

Either way, r=me

More information about the webkit-reviews mailing list