[webkit-reviews] review denied: [Bug 3233] CSS2: Web Kit does not support the :lang pseudo-class : [Attachment 2388] patch rev 2.0 alpha 1

bugzilla-request-daemon at opendarwin.org bugzilla-request-daemon at opendarwin.org
Wed Dec 28 02:06:59 PST 2005

Eric Seidel <macdome at opendarwin.org> has denied Eric Seidel
<macdome at opendarwin.org>'s request for review:
Bug 3233: CSS2: Web Kit does not support the :lang pseudo-class

Attachment 2388: patch rev 2.0 alpha 1

------- Additional Comments from Eric Seidel <macdome at opendarwin.org>
In general, I think this patch is good.  A couple comments:

1. I think that your additional "string-arg" member variable for CSSSelector
shoudl either be part of a union with simpleSelector, or should be part of a
subclass of CSSSelector.  Either way, we should only pay 4bytes for
simpleSelector and string_arg (bad name, btw) not 8, like we currently are.

Second, I think that NOTFUNCTION can just be replaced by "not(" in the actual
grammar if you like.

No need to add any //kdDebug lines, we're removing those as we go.

When we go about adding nth-* selectors, I don't think we'll keep the string
value in CSSSelector (we might).  We'll probably have bison do the actual an+b
parsing for us, and store a,b on CSSSelector (or more likely a subclass) as
floats perhaps.

More information about the webkit-reviews mailing list