[webkit-reviews] review denied: [Bug 4364] More event fixes : [Attachment 3323] Use get instead of getProperty

bugzilla-request-daemon at opendarwin.org bugzilla-request-daemon at opendarwin.org
Wed Aug 10 13:24:27 PDT 2005

Darin Adler <darin at apple.com> has denied Anders Carlsson <andersca at mac.com>'s
request for review:
Bug 4364: More event fixes

Attachment 3323: Use get instead of getProperty

------- Additional Comments from Darin Adler <darin at apple.com>
Darn, sorry, I missed this the first time:

+  if (handleEventFuncValue->isObject()) {
+      handleEventFunc = handleEventFuncValue->toObject(exec);

The toObject operation is too heavyweight. All we want here is a cast to
ObjectImp. I agree it's a little ugly to require a typecast -- maybe we should
make a nice wrapper function, but in any case, it should be:

    handleEventFunc = static_cast<ObjectImp *>(handleEventFuncValue);

Maybe we can figure out a nice elegant style of helper function to do this in a
way that makes code using it look nice.

Also, the "Bubbling second." comment no longer makes sense, so it should
probably be removed or revised.

More information about the webkit-reviews mailing list