<html><head></head><body bgcolor="#FFFFFF"><div><br><br>Von meinem iPhone gesendet</div><div><br>Anfang der weitergeleiteten E‑Mail:<br><br></div><blockquote type="cite"><div><b>Von:</b> Michael &lt;<a href="mailto:dres-schmidt@t-online.de">dres-schmidt@t-online.de</a>&gt;<br><b>Datum:</b> 29. August 2012 20:45:02 MESZ<br><b>An:</b> Andras Becsi &lt;<a href="mailto:abecsi@webkit.org">abecsi@webkit.org</a>&gt;<br><b>Betreff:</b> <b>Re: [webkit-qt] Qtwebkit-23 Build fails</b><br><br></div></blockquote><div></div><blockquote type="cite"><div><span></span><br><span></span><br><blockquote type="cite"><span>Hi,</span><br></blockquote><blockquote type="cite"><span></span><br></blockquote><blockquote type="cite"><span>On 29 August 2012 00:53, Michael &lt;<a href="mailto:dres-schmidt@t-online.de">dres-schmidt@t-online.de</a>&gt; wrote:</span><br></blockquote><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>28.08.2012, 16:33, "Michael" &lt;<a href="mailto:dres-schmidt@t-online.de">dres-schmidt@t-online.de</a>&gt;:</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>Hi All,</span><br></blockquote></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>when using Visual Studio 2010 to build QtWebkit 2.3 fromhttps://gitorious.org/+qtwebkit-developers/webkit/qtwebkit-23 with binaries/source Qt 4.8.2 installed,</span><br></blockquote></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>i do get the following link errors:</span><br></blockquote></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span> &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;link /LIBPATH:"p:\qtwebkit-23\WebKitBuild\Debug\lib" /LIBPATH:"c:\Qt\4.8.2\lib" /NOLOGO /DYNAMICBASE /NXCOMPAT /DEBUG /DLL /MANIFEST /MANIFESTFILE:"obj/debug\qmlwebkitplugind.intermediate.manifest" /OUT:..\imports\QtWebKit\qmlwebkitplugind.dll @C:\Users\mike\AppData\Local\Temp\nmE0BC.tmp &nbsp;&nbsp;Creating library ..\imports\QtWebKit\qmlwebkitplugind.lib and object ..\imports\QtWebKit\qmlwebkitplugind.expqdeclarativewebview.obj : error LNK2001: unresolved external symbol "public: static struct QMetaObject const QWebPage::staticMetaObject" (?staticMetaObject@QWebPage@@2UQMetaObject@@B)plugin.obj : error LNK2001: unresolved external symbol "public: static struct QMetaObject const QWebPage::staticMetaObject" (?staticMetaObject@QWebPage@@2UQMetaObject@@B)moc_qdeclarativewebview_p.obj : error LNK2001: unresolved external symbol "public: static struct QMetaObject const QWebPage::staticMetaObject" (?staticMetaObject@QWebPage@@2UQMetaObject@@B)qdeclarativewebview.obj : error LNK20</span><br></blockquote></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><span>01: unresolved external symbol "public: static struct QMetaObject const QGraphicsWebView::staticMetaObject" (?staticMetaObject@QGraphicsWebView@@2UQMetaObject@@B)plugin.obj : error LNK2001: unresolved external symbol "public: static struct QMetaObject const QGraphicsWebView::staticMetaObject" (?staticMetaObject@QGraphicsWebView@@2UQMetaObject@@B)moc_qdeclarativewebview_p.obj : error LNK2001: unresolved external symbol "public: static struct QMetaObject const QGraphicsWebView::staticMetaObject" (?staticMetaObject@QGraphicsWebView@@2UQMetaObject@@B)qdeclarativewebview.obj : error LNK2001: unresolved external symbol "public: static struct QMetaObject const QWebFrame::staticMetaObject" (?staticMetaObject@QWebFrame@@2UQMetaObject@@B)..\imports\QtWebKit\qmlwebkitplugind.dll : fatal error LNK1120: 3 unresolved externals</span><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>Looks like some moc files were not generated. How do you build QtWebKit?</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><span>I followed <a href="http://trac.webkit.org/Wiki/buildingqtonwindows">trac.webkit.org/Wiki/buildingqtonwindows</a></span><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>System is Windows 7 64bit.</span><br></blockquote></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>Do I have to build Qt 4.8.2 from source with -qtwebkit? I now just installed the VS-2010 binaries.</span><br></blockquote></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>No, having another QtWebKit around may even make things worse.</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><span>Sorry, I meant Build with configue -no-webkit. Because right now i do have the precompiled binaries installed which Include the webkit.</span><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>--</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>Regards,</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><blockquote type="cite"><span>Konstantin</span><br></blockquote></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><span></span><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><span>So should I Build qt 4.8.2. from source with configue -no-webkit first?</span><br></blockquote></blockquote><blockquote type="cite"><blockquote type="cite"><span>Thanks and best Regards,</span><br></blockquote></blockquote><blockquote type="cite"><span></span><br></blockquote><blockquote type="cite"><span>Yes, you need to configure Qt with -no-webkit before you try to build</span><br></blockquote><blockquote type="cite"><span>a custom QtWebKit because your linker most probably tries to link to</span><br></blockquote><blockquote type="cite"><span>the installed libraries and that obviously fails.</span><br></blockquote><blockquote type="cite"><span></span><br></blockquote><blockquote type="cite"><span></span><br></blockquote><blockquote type="cite"><span>/Andras</span><br></blockquote><span></span><br><span>Hi Andras,</span><br><span>Rebuild 4.8.2 with -no-webkit. Same errors. I think either the qtwebkit-23 repo is not working or at least Not with 4.8.2. </span><br><span>Has anyone compiled the qtwebkit-23 repo successfully and with which version ?</span><br><span></span><br><span>Thanks,</span><br><span>Mike</span></div></blockquote></body></html>