Say I&#39;m developing a WYSIWYG HTML editor. If I input as<div><br></div><div>1st line</div><div>2nd line</div><div><br></div><div>QWebFrame will give me as</div><div><br></div><div>1st line&lt;div&gt;2nd line&lt;/div&gt;</div>

<div><br></div><div>But this code could not get the same output in other browsers, for there is no</div><div>any new line tag such as &lt;br/&gt; or &lt;p&gt;.</div><div><br><br><div class="gmail_quote">2012/8/15 Coda Highland <span dir="ltr">&lt;<a href="mailto:chighland@gmail.com" target="_blank">chighland@gmail.com</a>&gt;</span><br>

<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div class="im">On Tue, Aug 14, 2012 at 8:13 PM, 程梁 &lt;<a href="mailto:chengliang.soft@gmail.com">chengliang.soft@gmail.com</a>&gt; wrote:<br>


&gt; I&#39;m afraid not, for this will return just return<br>
&gt;<br>
&gt; hey&lt;div&gt;newline&lt;/div&gt;.<br>
&gt;<br>
&gt; the tags are still wrong.<br>
&gt;<br>
&gt; Maybe I should embed an online HTML WYSIWYG editor...<br>
<br>
</div>Afraid I don&#39;t understand how those tags are wrong. It should produce<br>
exactly the same output as you put into it.<br>
<br>
/s/ Adam<br>
</blockquote></div><br><br clear="all"><div><br></div>-- <br>Cheng Liang<a href="http://about.me/devbean" target="_blank"></a><br>Nanjing, China<br><a href="http://www.devbean.info" target="_blank">http://www.devbean.info</a><br>

from: <a href="mailto:devbean@devbean.info" target="_blank">devbean@devbean.info</a><br>
</div>