<span class="Apple-style-span" style="font-family: arial, sans-serif; font-size: 18px; background-color: rgb(255, 255, 255); "><div> I found a blog and follow it(<a href="http://blog.csdn.net/cnnzp/article/details/6576934" target="_blank" style="color: rgb(0, 0, 204); ">http://blog.csdn.net/cnnzp/article/details/6576934</a> it's Chinese) I can debug it in Ubuntu.</div>
<div>    But when I build it windows, there is an err</div><div><span style="font-family: 'AR PL UKai CN'; font-size: medium; "><pre style="white-space: pre-wrap; word-wrap: break-word; ">make: *** [sub-WebKit-qt-QtWebKit-pro-make_default-ordered] error 2
*************************************************************
Cannot find 'C:\Program Files\Microsoft Visual Studio 8\Common7\IDE\VCExpress.ex
e'
Please execute the file 'vcvars32.bat' from
'C:\Program Files\Microsoft Visual Studio 8\VC\bin\'
to setup the necessary environment variables.</pre></span></div><div>    Before I run perl Tools/Scripts/build-webkit, I have run Qt Command Prompt.</div><div>    I installed <span style="font-family: monospace; white-space: pre-wrap; font-size: medium; ">Qt SDK by Nokia v2010.05 (open source)(it should be qt 4.7.1) which include mingw and qt. </span></div>
<div><span style="font-family: monospace; white-space: pre-wrap; font-size: medium; ">  It seems the perl script trying to use vs2008(I have installed vs 2008 express)</span></div><div>    Here are my env variables, I don't find any related to vs2008</div>
<div><span style="font-family: 'AR PL UKai CN'; font-size: medium; "><pre style="white-space: pre-wrap; word-wrap: break-word; ">ALLUSERSPROFILE=C:\Documents and Settings\All Users
APPDATA=C:\Documents and Settings\Administrator\Application Data
APR_ICONV_PATH=C:\Program Files\Subversion\iconv
CLASSPATH=E:\apache-ant-1.7.1\lib
CLIENTNAME=lili
CommonProgramFiles=C:\Program Files\Common Files
COMPUTERNAME=LILI-HOME
ComSpec=C:\WINDOWS\system32\cmd.exe
FP_NO_HOST_CHECK=NO
gwpath=C:\Program Files\O2Micro\Succendo
HOMEDRIVE=C:
HOMEPATH=\Documents and Settings\Administrator
JAVA_HOME=C:\Program Files\Java\jdk1.6.0_11
LOGONSERVER=\\LILI-HOME
NUMBER_OF_PROCESSORS=4
OPENSSL_CONF=C:\OpenSSL-Win32\bin\openssl.cfg
OS=Windows_NT
Path=C:\Qt\2010.05\qt\bin;C:\Qt\2010.05\bin;C:\Qt\2010.05\mingw\bin;D:\Perl\bin;
D:\Python27;D:\GnuWin32\bin;C:\WINDOWS\System32
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH
PROCESSOR_ARCHITECTURE=x86
PROCESSOR_IDENTIFIER=x86 Family 6 Model 23 Stepping 10, GenuineIntel
PROCESSOR_LEVEL=6
PROCESSOR_REVISION=170a
ProgramFiles=C:\Program Files
PROMPT=$P$G
QMAKESPEC=win32-g++
QTDIR=C:\Qt\2010.05\qt
SESSIONNAME=RDP-Tcp#1
SystemDrive=C:
SystemRoot=C:\WINDOWS
TEMP=C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp
TMP=C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp
USERDOMAIN=LILI-HOME
USERNAME=Administrator
USERPROFILE=C:\Documents and Settings\Administrator
windir=C:\WINDOWS</pre></span></div></span>