<font size="2"><font face="tahoma,sans-serif">Hi,<br></font></font><br><div class="gmail_quote">On Fri, May 7, 2010 at 11:54 AM, Jocelyn Turcotte <span dir="ltr">&lt;<a href="mailto:jocelyn.turcotte@nokia.com">jocelyn.turcotte@nokia.com</a>&gt;</span> wrote:<br>

<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;"><div class="im">On 5/6/2010 6:44 PM, ext İsmail Dönmez wrote:<br>
</div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Hi again;<div class="im"><br>
<br>
On Wed, May 5, 2010 at 1:58 PM, Markus Goetz &lt;<a href="mailto:Markus.Goetz@nokia.com" target="_blank">Markus.Goetz@nokia.com</a> &lt;mailto:<a href="mailto:Markus.Goetz@nokia.com" target="_blank">Markus.Goetz@nokia.com</a>&gt;&gt; wrote:<br>


<br>
    ext İsmail Dönmez wrote:<br>
<br>
        Hi all;<br>
<br>
        When I buid WebKit from source with debug enabled the<br>
        QtWebKitd4.dll file is ~60mb which is huge. If you build<br>
        WebKit inside Qt the debug dll size is ~20mb or so. Any idea<br>
        what causes this big size change?<br>
<br>
        P.S: I am building with Visual Studio 2005<br>
<br>
    Check the end of src/3rdparty/webkit/WebCore/WebCore.pro in the Qt<br>
    source where it says something about debug info.<br>
<br>
<br>
I took the debug part out of QTDIR_build to enable it for all cases but it doesn&#39;t seem to work, any ideas how to get it working for standalone WebKit build?<br>
<br>
</div></blockquote>
It is sure you&#39;ll have to call an &quot;nmake clean&quot; to make it work.<br>
Beside that I think it should work if you just remove the &quot;CONFIG(QTDIR_build)&quot; condition.<br>
<br>
You could also try to start a debug/release build and edit the Makefile.Debug/Makefile.Release file to change the compilation flags to the ones you want if you want to test something (though your change will be overwritten if you touch WebCore.pr?).<br>


<br></blockquote><div><br></div><div>I am sure I did a build  from scratch. I will try editing Makefile.Debug directly.</div><div><br></div><div>Thanks,</div><div>ismail</div><div><br></div></div>