[webkit-qt] toUpperCase() bug in Qt5.1 RC

Bruning Michael Michael.Bruning at digia.com
Tue Jul 2 05:40:12 PDT 2013

Hi all,

On Tuesday, 2nd July  2013 at 13:48, Richard Gerd Kuesters wrote:
> I built Qt 5.1 RC2 yesterday in my Linux box and the bug does not occur in here.
I tried this locally with rc1 on Windows 8 64 bit / VS2012 and Windows 7 32 bit / VS2010 and Linux 64 Bit. Also, a colleague tried to reproduce on with rc2 Windows 7 64 Bit / VS 2012 but did not get the described bug.

I have also scanned the diff between the 5.1 beta1 and rc1 and there are very few javascript related changes with the huge majority only affecting MIPS and the others not really touching string handling.

Eike, could you please help and provide a bit more info on the context so we can try to see if this is an issue that might be more widespread? It would e.g. be interesting to know if it happened with an installed package or Qt built from source, which locale the system is set to, which version of ICU was used etc... 

Thanks and best regards,

Michael Brüning, Senior Software Engineer - Digia, Qt
Digia Germany GmbH, Rudower Chaussee 13, D-12489 Berlin
Geschäftsführer: Mika Pälsi, Juha Varelius, Anja Wasenius
Sitz der Gesellschaft: Berlin. USt-IdNr: DE 286 306 868
Registergericht: Amtsgericht Charlottenburg, HRB 144331 B

More information about the webkit-qt mailing list