[webkit-qt] QtWebkit with MSVC 2012 RC Win x86

Vivekanand Rajkumar viv.rajkumar at maidsafe.net
Mon Jun 25 21:05:44 PDT 2012

Hey Guys,

have any of you tried to use webkit-qt with MSVC 2012RC ?

I've got qt  4.8.2 from git HEAD to build with this fix (

However when running the application (even qt examples using webkit) in
release mode, the application crashes at setUrl/setHtml of QWebView with an
invalid access exception. Looks like a memory allocation error.

This only happens in release builds and not in debug and the same situation
does not occur in x64 with MSVC 2012RC

I've tried multiple things to no success. Really hoping one of you guys
could give me some guidance with this issue.

(Am not able to check the code run in the background even from debug mode
to try and fix this cos for some reason Visual studio does not let me step
into any QtWebKit function calls even when it says it has symbols loaded
for the correct dll.)

Thank you,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-qt/attachments/20120626/7099e23c/attachment.html>

More information about the webkit-qt mailing list