[webkit-qt] A general rule for naming our files (and classes)

Caio Marcelo de Oliveira Filho caio.oliveira at openbossa.org
Thu Oct 13 06:06:42 PDT 2011


Hello,

What about using the following guide to name our files?

- Public API follow Qt conventions: qsomething.cpp qsomething.h and are named
- Private classes for public API classes follow Qt conventions:
qsomething_p.h qsomething_p.cpp (if needed)
- Subclasses and Qt-specific implementations of WebKit/WebCore classes
use Qt suffix: FrameLoaderClientQt.cpp
- Other classes created for using in our port use Qt prefix:
QtFileDownloader, QtViewInterface

This is the best convention I could extract from existing practices.
If we agree on this rule,
I'll write it down in the http://trac.webkit.org/wiki/QtWebKitHacking
page and the
following files/classes would be renamed or have the file names adjusted:

* UIProcess/qt:

PolicyInterface -> QtPolicyInterface
qdesktopwebpageproxy -> QtDesktopWebPageProxy
qtouchwebpageproxy -> QtTouchWebPageProxy
qweberror -> QtWebError
SGTileNode -> QtSGTileNode
SGUpdateQueue -> QtSGUpdateQueue
TouchViewInterface -> QtTouchViewInterface
ViewInterface -> QtViewInterface
ViewportInteractionEngine -> QtViewportInteractionEngine
WebUndoCommandQt -> QtWebUndoCommand

qwk* files remain as is and will be renamed next time someone work with them.


* WebProcess/WebCoreSupport/qt:

WebFrameNetworkingContext -> WebFrameNetworkingContextQt
(Web prefix here to differentiate from WK1 file)


Cheers,

-- 
Caio Marcelo de Oliveira Filho
OpenBossa - INdT


More information about the webkit-qt mailing list