[webkit-qt] git confusion - pull to update is merging entire tree

Ademar Reis ademar.reis at openbossa.org
Mon Apr 25 12:42:22 PDT 2011

On Sun, Apr 24, 2011 at 9:31 AM, Lindsay Mathieson
<lindsay.mathieson at gmail.com> wrote:
> I have a git clone of master (git at gitorious.org:webkit/webkit.git)
> from a couple of weeks back. I've made some minor changes to several
> files in QtWebKit and QtTestBrowser, commited them and just tried to
> do a "git pull" to update from master.
> It downloaded over 600MB, tried to merge what looked like the entire
> source tree which failed with a conflict problem - not sure where.

Are you sure you just cloned? Did you add any remotes or other repositories?

There are a few webkit git repositories around but not all of them are
compatible. Your problem sounds like merging two
different/incompatible git trees. For example,
git at gitorious.org:webkit/webkit.git is different than

If in doubt, check your .git/config file from inside the project dir.

   - Ademar

Ademar de Souza Reis Jr. <ademar.reis at openbossa.org>
OpenBossa - Instituto Nokia de Tecnologia

More information about the webkit-qt mailing list