[webkit-qt] Qt Webkit 4.5.3 and Flash

İsmail Dönmez ismail at namtrac.org
Fri Jun 4 01:14:32 PDT 2010

GTK needs a patch similar to
Or you can call gtk_init in your application.


On Fri, Jun 4, 2010 at 11:10 AM, Rajendra Prasad Murakonda <
rajendra.prasad at gmail.com> wrote:

> I have been trying to run flash videos in QWebPage. With
> WebSettings::PluginsEnabled set to true, it works seamlessly in Windows XP.
> But I am unable to make it work in RHEL 4 server.
> If I try with flash player plugin 10 or 7 in Linux, a small image shows up
> instead of Flash in QWebPage. If I try Flash player plugin 9, I get the
> following error, and a white page is displayed with some sort of grid on it.
> ==
> process:2710): GLib-GObject-CRITICAL **: gtype.c:2253: initialization
> assertion failed, use g_type_init() prior to this function
> (process:2710): Gtk-CRITICAL **: file gtkclipboard.c: line 213
> (gtk_clipboard_get_for_display): assertion `GDK_IS_DISPLAY (display)' failed
> Adobe Flash Player: gtk_clipboard_get(GDK_SELECTION_PRIMARY); failed.
> Trying to call gtk_init(0,0);
> ==
> I have tried most released versions of flash player 9 plugin for Linux with
> the same result. Where as flash works fine in Firefox. So is this some sort
> of GTK version mismatch for Webkit and Flash? All this makes Flash unusable
> with Webkit on our platform matrix.
> Most importantly is there any other way to run flash videos without using
> Flash plugin by Adobe? I couldn't compile Phonon because of the dbus-1
> version mismatch. Is there any other alternative?
> Any help is much appreciated.
> Rajendra Prasad Murakonda,
> http://prodizy.livejournal.com/
> _______________________________________________
> webkit-qt mailing list
> webkit-qt at lists.webkit.org
> http://lists.webkit.org/mailman/listinfo.cgi/webkit-qt
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-qt/attachments/20100604/d03400d1/attachment.html>

More information about the webkit-qt mailing list