That&#39;s because the browser _will_ chop this part of this URL.<br>&#39;#&#39; is a reserved part of the URI scheme, after which all characters are considered as a &quot;fragment id&quot;, which is _never_ sent to the website. This part of the URL stays local to the browser.<br>

<br>Actual websites using this scheme as a way to navigate must use a Javascript code, executed on the client side, that will load the correct content through AJAX.<br><br>I tested in a Qt5.0.1 WebView (QML), and I have no problem loading your URL.<br>

<br>So, wild guess here, do you have Javascript enabled in your webview?<br><br><br><br><div class="gmail_quote">On Thu, Feb 7, 2013 at 8:37 PM, y w <span dir="ltr">&lt;<a href="mailto:ytrac00@yahoo.com" target="_blank">ytrac00@yahoo.com</a>&gt;</span> wrote:<br>

<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><table border="0" cellpadding="0" cellspacing="0"><tbody><tr><td style="font:inherit" valign="top"><br><br>--- On <b>Thu, 2/7/13, y w <i>&lt;<a href="mailto:ytrac00@yahoo.com" target="_blank">ytrac00@yahoo.com</a>&gt;</i></b> wrote:<br>

<blockquote style="border-left:2px solid rgb(16,16,255);margin-left:5px;padding-left:5px"><br>From: y w &lt;<a href="mailto:ytrac00@yahoo.com" target="_blank">ytrac00@yahoo.com</a>&gt;<br>Subject: Webkit chops the URL with character &quot;#&quot; ?<br>

To: <a href="mailto:webkit-help@lists.webkit.org" target="_blank">webkit-help@lists.webkit.org</a><br>Received: Thursday, February 7, 2013, 2:35 PM<div><div class="h5"><br><br><div><table border="0" cellpadding="0" cellspacing="0">

<tbody><tr><td style="font:inherit" valign="top">Hi All,<div><br></div><div>I found issue of processing URL: </div><div>I create a simple webview and load page from a url string, it works fine for most given urls but not good for  <a rel="nofollow" href="http://money.cnn.com/m/#!/2013/02/06/news/economy/postal-service-cuts.json?category=Latest%20News" target="_blank">http://money.cnn.com/m/#!/2013/02/06/news/economy/postal-service-cuts.json?category=Latest%20News</a>.</div>

<div>if I encode the url as <a rel="nofollow" href="http://money.cnn.com/m%2F%23%21%2F2013%2F02%2F06%2Fnews%2Feconomy%2Fpostal%2Dservice%2Dcuts%2Ejson%3Fcategory%3DLatest%20News" target="_blank">http://money.cnn.com/m%2F%23%21%2F2013%2F02%2F06%2Fnews%2Feconomy%2Fpostal%2Dservice%2Dcuts%2Ejson%3Fcategory%3DLatest%20News</a></div>

<div>it will give another error page.</div><div>I got always the page  <a rel="nofollow" href="http://money.cnn.com/m" target="_blank">http://money.cnn.com/m</a> which is home
 page of the news not the exactly article page. But if I input the full url in any browser(Safari, Firefox, chrome) it works fine.</div><div>It seams the url been chopped from &quot;#&quot; character by webkit.</div><div>

This happen for both Mac and Linux: I am using the night dump WebKit-r116865, tested with Cocoa application(iMac),  Ubuntu 12.04  GTK. </div><div><br></div><div>Does any one know why?</div><div><br></div><div>Thanks,</div>

<div>Yang</div><div>  </div></td></tr></tbody></table></div></div></div></blockquote></td></tr></tbody></table>
<br>_______________________________________________<br>
webkit-help mailing list<br>
<a href="mailto:webkit-help@lists.webkit.org">webkit-help@lists.webkit.org</a><br>
<a href="https://lists.webkit.org/mailman/listinfo/webkit-help" target="_blank">https://lists.webkit.org/mailman/listinfo/webkit-help</a><br>
<br></blockquote></div><br>