<html><head>
<meta http-equiv="Content-Type" content="text/html; charset=Windows-1252"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; color: rgb(0, 0, 0); font-size: 14px; font-family: Calibri, sans-serif; "><div>I have been attempting to build webkit with the –coverage argument (as well as run the generate-coverage-data script), and am receiving the error below.  Does anyone have experience building with –coverage or running the coverage script?  </div><div><br></div><div><br></div><div>…..</div><div><br></div><div><div>clang: warning: argument unused during compilation: '-MMD'</div><div><br></div><div>Ld /Users/jacobg/WebKit/WebKitBuild/Release/JavaScriptCore.framework/Versions/A/JavaScriptCore normal x86_64</div><div>    cd /Users/jacobg/WebKit/Source/JavaScriptCore</div><div>    setenv MACOSX_DEPLOYMENT_TARGET 10.7</div><div>    /Developer/usr/bin/clang++ -arch x86_64 -dynamiclib -L/Users/jacobg/WebKit/WebKitBuild/Release -F/Users/jacobg/WebKit/WebKitBuild/Release -filelist /Users/jacobg/WebKit/WebKitBuild/JavaScriptCore.build/Release/JavaScriptCore.build/Objects-normal/x86_64/JavaScriptCore.LinkFileList -Xlinker --no-demangle -exported_symbols_list /Users/jacobg/WebKit/WebKitBuild/Release/DerivedSources/JavaScriptCore/JavaScriptCore.JSVALUE64.exp -install_name /Users/jacobg/WebKit/WebKitBuild/Release/JavaScriptCore.framework/Versions/A/JavaScriptCore -mmacosx-version-min=10.7 -dead_strip -lobjc -Wl,-Y,3 -sub_library libobjc -framework CoreServices -Xlinker -objc_gc_compaction -ftest-coverage -fprofile-arcs -lgcov -fprofile-arcs -ftest-coverage -framework CoreFoundation -framework Foundation -licucore -lobjc -single_module -compatibility_version 1 -current_version 535.16 -o /Users/jacobg/WebKit/WebKitBuild/Release/JavaScriptCore.framework/Versions/A/JavaScriptCore</div><div><b>ld: library not found for -lgcov</b></div><div>Command /Developer/usr/bin/clang++ failed with exit code 1</div><div><br></div><div><br></div><div>** BUILD FAILED **</div><div><br></div><div><br></div><div>The following build commands failed:</div><div><span class="Apple-tab-span" style="white-space:pre">     </span>Ld /Users/jacobg/WebKit/WebKitBuild/Release/JavaScriptCore.framework/Versions/A/JavaScriptCore normal x86_64</div><div>(1 failure)</div></div></body></html>