Hello,<br><br>I'm trying to install Webkit on Ubuntu, but I get the following erro when I try to make it:<br><br>WebCore/plugins/gtk/PluginViewGtk.cpp: In member function ‘void WebCore::PluginView::init()’:<br>WebCore/plugins/gtk/PluginViewGtk.cpp:552: error: ‘NPSetWindowCallbackStruct’ was not declared in this scope<br>

WebCore/plugins/gtk/PluginViewGtk.cpp:552: error: ‘ws’ was not declared in this scope<br>WebCore/plugins/gtk/PluginViewGtk.cpp:552: error: expected type-specifier before ‘NPSetWindowCallbackStruct’<br>WebCore/plugins/gtk/PluginViewGtk.cpp:552: error: expected ‘;’ before ‘NPSetWindowCallbackStruct’<br>

WebCore/plugins/gtk/PluginViewGtk.cpp:572: error: ‘struct NPWindow’ has no member named ‘ws_info’<br>make[1]: *** [WebCore/plugins/gtk/libWebCore_la-PluginViewGtk.lo] Error 1<br>make[1]: Leaving directory `/home/screamer/Canmore/usr/src/WebKit-r36247'<br>

make: *** [all] Error 2<br><br><br>I tried looking at the PluginViewGtk.cpp file, but I'm not sure how to fix this. Can anyone help?<br><br><br>Best regards,<br><font color="#888888">Tom</font>