<br><br><div class="gmail_quote">On Wed, Dec 1, 2010 at 12:05 PM, Shanfeng Cheng <span dir="ltr">&lt;<a href="mailto:sfcheng@gmail.com">sfcheng@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">




<div style="margin-top: 10px; margin-left: 10px; margin-right: 10px;" bgcolor="#eaeaea">Hello, Nimish Nayak: 
<div> </div>
<div><font face="宋体"></font></div>
<div>These errors are projects depending on other projects to be successfully 
built first. Go all the way back and find the very first error. </div>
<div> </div>
<div>  
<div>Best regards. </div>
<div> </div>
<div>
<div><font face="宋体"><div class="im">
<div><font face="宋体"><span>Shanfeng Cheng</span><br></font><font face="宋体"><a href="mailto:sfcheng@gmail.com" target="_blank">sfcheng@gmail.com</a></font></div>
</div><div><font face="宋体">2010-12-01</font><br></div></font></div></div></div></div><br></blockquote></div><br clear="all">I tried the solution provided by joseph on <a href="http://social.msdn.microsoft.com/forums/en-US/vcgeneral/thread/871103ca-6015-40ce-8a59-92e47ce68aeb/">http://social.msdn.microsoft.com/forums/en-US/vcgeneral/thread/871103ca-6015-40ce-8a59-92e47ce68aeb/</a><br>
My $(path) environment variable does not include the path to cmd.exe, So i re-built the project after doing so. It still gave errors.<br><br>I traced where the first error came about and its this <br>c:\cygwin\home\nimesh\webkit\javascriptcore\wtf\PassRefPtr.h(98) : error C2220:<br>
warning treated as error - no &#39;object&#39; file generated<br>        c:\cygwin\home\nimesh\webkit\javascriptcore\wtf\text\StringImpl.h(113) :<br> see reference to class template instantiation &#39;WTF::PassRefPtr&lt;T&gt;&#39; being compil<br>
ed<br>        with<br>        [<br>            T=WTF::StringImpl<br>        ]<br><br>Do i need to download <a href="http://www.microsoft.com/downloads/en/details.aspx?FamilyId=FBEE1648-7106-44A7-9649-6D9F6D58056E&amp;displaylang=en">http://www.microsoft.com/downloads/en/details.aspx?FamilyId=FBEE1648-7106-44A7-9649-6D9F6D58056E&amp;displaylang=en</a> as SP1 is required for Microsoft Visual Studios 2005 .  <br>
<br>-- <br>Nimish<br><br>