[webkit-help] Compiling webkit on windows.

Brent Fulgham bfulgham at apple.com
Mon Nov 16 10:00:47 PST 2020

Hi Jean-Yves,

It looks like you are building and running an Apple-style build of WebKit. We have a set of support libraries (AAS) that have to be in the environment of the executable for things to work properly.

You might need to install iTunes, which contains the runtime libraries, to get those onto your machine.
https://www.apple.com/itunes/ <https://www.apple.com/itunes/>

The bundle you downloaded to do the build contains the headers and link libraries, but does not contain the DLLs or other runtime elements.

I’ve been working (not very much) on a DirectX-based Windows build to avoid this complexity. But for now, I think you need to install a current version of iTunes.



> On Nov 16, 2020, at 12:24 AM, Jean-Yves Avenard <jyavenard at gmail.com> wrote:
> Ok, that compiled. "WebKit is now built (13m:40s)."
> but running perl .\Tools\Scripts\run-safari gives a window showing
> "Failed to determine path to AAS directory".
> Ideas?
> JY
> On Mon, 16 Nov 2020 at 18:24, Jean-Yves Avenard <jyavenard at gmail.com> wrote:
>> Hi
>> Yeah, I'm seeing this:
>> https://community.activestate.com/t/free-to-wrong-pool-in-ssl-pm/2160
>> I was using the ActivePerl 5.28, tried with 5.26 and same error.
>> Now running strawberry perl and no longer getting the ICU error, but
>> plenty of others. But at least those have a clearer error message so
>> I'll resolve those first and see how it goes.
>> Thanks !
>> On Mon, 16 Nov 2020 at 18:07, Fujii Hironori <fujii.hironori at gmail.com> wrote:
>>> Hi,
>>> You have to get the message "Current WebKitAuxiliaryLibrary is up to date." for update-webkit-auxiliary-libs.
>>> You seem to have a SSL related error.
>>>> Free to wrong pool 10b6e70 not 9500690069c1fc30 at
>>>> C:/Perl64/site/lib/IO/Socket/SSL.pm line 2739.
>>> Can you try other Perl, for example, Cygwin Perl, ActivePerl, or Strawberry Perl?
> _______________________________________________
> webkit-help mailing list
> webkit-help at lists.webkit.org
> https://lists.webkit.org/mailman/listinfo/webkit-help

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-help/attachments/20201116/42c10ad8/attachment.htm>

More information about the webkit-help mailing list