[webkit-help] midori/empathy Crashing

Andreas Mattheiss andreas.mattheiss at gmx.de
Fri Mar 28 08:39:43 PDT 2014


I've been trying to get webkit onto my machine, building from source. I tried both full-blown webkits and the webkitgtk - editions. Virtually everything on my system is self-compiled.

Most recent installments wouldn't build due to dependencies I'm unwilling to satisfy by upgrading, but versions that do build are webkit-1.9.6 (from wekkitgtk) and WebKit-r133122 (from upstream) and others.

The trouble starts why I run midori since the browser starts to load a page but then crashes with

INTERNAL ERROR on Browser End: Some problem with the version 5

I'm 100% sure it's not midori but webkit that's causing this - when I build epiphany exactly the same happens. The funny thing though is that some pages load ok, such as slackware.com or debian.org. Clicking onto midori's "setting" menu item however causes the browser to crash. If it does crash, it does so after having rendered the page. I've also built a recent liferea against this; this works ok though.

Is there anything that I could try here - as I said virtually everything on my box is self-compiled, but configure obviously finds the right versions. Maybe there are some typical libraries that might cause this and thus need attention?


More information about the webkit-help mailing list