[webkit-help] Has anyone used XCode 4.3.1 (4E1019) ?

sm webkit smwebkit at gmail.com
Wed Mar 14 10:49:04 PDT 2012

Just wanted to mention that finally I am able to build the latest webkit
tree on both command line (build-webkit script) and with Xcode 4.3.1 IDE !
The removal of Older XCode was causing problem because the in new
Xcode4.3.1 developer directory has moved. I ran the following command to
set the path and it worked
sudo xcode-select -switch /Applications/Xcode.app/Contents/Developer

On Tue, Mar 13, 2012 at 12:44 PM, sm webkit <smwebkit at gmail.com> wrote:

> Hi Ariya,
> Yes, I've tried that.
> I am in bind. I upgraded to Xcode4.3.1 and completely removed older
> versions of XCode.
> So all the Path variables etc are gone but the build scripts are not
> modified yet.
> The new XCode 4.3.1 is installed via Appstore and gets installed in the
> Applications folder.
> So the procedure listed at the link you sent fails because build-webkit
> script cannot find Xcodebuild. Infact after installing xcode4.3.1 I cannot
> locate where xcodebuild is!
> here is the error.
> /build-webkit
> error: can't exec '/Applications/usr/bin/xcodebuild' (No such file or
> directory)
> *************************************************************
> Xcode Version 2.3 or later is required to build WebKit.
> You have an earlier version of Xcode, thus the build will
> most likely fail.  The latest Xcode is available from the web:
> http://developer.apple.com/tools/xcode
> *************************************************************
> thanks! for the fast response.
> I even tried starting from scratch, i.e downloading and installing, XCode
> 4.3.1 from the tar file, installing the webkit tar and updating the tree
> and then building from within xcode4.3.1 but no success.
> Every .xcodeproj build except for webkit.xcodeproj.
> I am ok with building with Command line, just that scripts are failing,
> likely because my environment is messed up.
> please help.
> SM
> On Tue, Mar 13, 2012 at 11:43 AM, Ariya Hidayat <ariya.hidayat at gmail.com>wrote:
>> > Sorry for the generic question, but has anyone used Xcode4.3.1 to build
>> the
>> > latest Webkit successfully?
>> > I am able to open and build the Xcodeproj for Javascript, Webcore,
>> Webkit2).
>> > But when I open the webkit.xcodeproj file there are no targets defined,
>> I
>> > defined my own target but it fails.
>> You should always check first if building in command-line works or
>> not. See http://www.webkit.org/building/build.html.
>> --
>> Ariya Hidayat, http://ariya.ofilabs.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-help/attachments/20120314/034b3017/attachment.html>

More information about the webkit-help mailing list