[webkit-help] update-webkit script error

Praveen Munukutla munukutlapraveen at gmail.com
Tue Feb 21 03:35:13 PST 2012

Adam Roben <aroben at ...> writes:

> On Jun 13, 2010, at 10:06 PM, Eric Zhou wrote:
> Hi all,
> When I run update-webkit script, I got following error message:
> Checking Last-Modified date of WebKitAuxiliaryLibrary.zip...
> Couldn't check Last-Modified date of new WebKitAuxiliaryLibrary.zip. Please 
ensure that http://developer.apple.com/opensource/internet/WebKitAuxiliar
> yLibrary.zip is reachable.
> Unable to check Last-Modified date and no version of WebKitAuxiliaryLibrary to 
f all back to.
> I have tried several times to get WebKitAuxiliaryLibrary.zip 
 from http://developer.apple.com/opensource/internet/WebKitAuxiliaryLibrary.zip.
It does not work. Is that zip file moved to another location?
> This was a bug on Apple's side. It has been fixed now. Please let us know if 
you run into any more trouble, and sorry for the inconvenience!
> -Adam

Hi folks,

here is the workaround for this issue.

try to download the 
tAuxiliaryLibrary.zip) from the link given in the update-webkit-auxiliary-libs 
and place that zip file in your localhost and modify the link in the update-
webkit-auxiliary-libs script
(my $auxiliaryLibsURL = "http://localhost/webkit/$zipFile";) and run it.
It will install the libs successfully.

~Praveen Munukutla

More information about the webkit-help mailing list