[webkit-help] Webkit Build error on Ubuntu 10
sknikam at gmail.com
Mon Sep 5 15:07:08 PDT 2011
1. As per this url (http://trac.webkit.org/wiki/BuildingGtk) webkit
recommends libgtk2.0-dev (>= 2.10) and libgail-dev
Although I have the libgtk2.0-dev package installed, It seems that the
configure.ac file (Starting line 188) is unable to detect it and is
going with the default gtk+ version=3.0.
Any ideas why this is happening?
2. As per this url (http://packages.ubuntu.com/natty/libgail-3-dev)
libgail-3-dev depends on libgtk-3-dev.
I updated my /etc/apt/sources.list as documented here
But aptitude is unable to locate the source for libgtk-3-dev
On Mon, Sep 5, 2011 at 2:05 AM, anand pandia <a.pandia at gmail.com> wrote:
> The library you need is "libgail-3-dev".
> On Mon, Sep 5, 2011 at 1:32 PM, sachin nikam <sknikam at gmail.com> wrote:
>> I tried
>> $ sudo apt-get install gail-3.0
>> but did not find any package by that name.
>> I am following the build instructions listed here
>> I did not find any mention of this package in the instructions, so not
>> sure what the value of env vars
>> GAIL_CFLAGS and GAIL_LIBS should be?
>> On Mon, Sep 5, 2011 at 12:36 AM, Ariya Hidayat <ariya.hidayat at gmail.com>
>> >> I get the following error, when I run the following command
>> >> Any ideas on what I am missing?
>> >> $ Tools/Scripts/build-webkit --gtk --debug
>> >> configure: error: Package requirements (gail-3.0 >= 3.0) were not met:
>> > I'm just stating the obvious: did you try to fulfill the above
>> > requirement?
>> > --
>> > Ariya
>> webkit-help mailing list
>> webkit-help at lists.webkit.org
More information about the webkit-help