[webkit-help] WebKit-gtk shows HTML source code when loading a local page

scostas scostas at det.uvigo.es
Fri Jan 8 04:43:10 PST 2010

Hi all:

I'm creating a little web browser using webkit-gtk from Gentoo (version 

When I use it from gentoo itself, it works fine. But since I want to 
embed it in a little system, I want to remove everything not needed, so 
I created a directory where I copied the executable itself, the 
ld-config program, all the libraries needed (I got them using ldd 
mybrowser), the /etc/pango, /etc/fonts, /etc/gtk-2.0 folders, 
/usr/share/fonts and /usr/lib/pango folders, and the ld.so.conf and 
resolv.conf files; then I run

    chroot myfolder /usr/bin/ld-config

to regenerate the ld.so.cache file, and I tryed to run my browser.

It worked, and showed pages like google, wikipedia, and so on, always 
loaded using http.

But (and here comes the problem), when I try to load a local page, using 
file:///path/to/my/file.html, it doesn't render the file, but just shows 
its HTML source code.

When I run my browser from the gentoo system, it works fine, both 
http:// and file://, so it seems a problem with a missing library or 
configuration file.

I copied the mime.types file too, but still doesn't work :(

Thanks in advance.

More information about the webkit-help mailing list