[webkit-gtk] WebkitGTK requires GTK 2 instead of GTK 3

christophe.jarry at ouvaton.org christophe.jarry at ouvaton.org
Fri Nov 1 13:44:35 PDT 2013


I have tried to build webkitgtk 2.3.1 with the following options:

./configure \
    --prefix=/usr \
    --disable-geolocation \
    --disable-gtk-doc-html \
    --disable-silent-rules \
    --disable-credential-storage \
    --disable-video \

And I get the error message below:

checking for GTK2... no
configure: error: Package requirements (gtk+-2.0 >= 2.24.10) were not met:

No package 'gtk+-2.0' found

Why does webkitgtk 2.3.1 requires me to have GTK 2 installed when I
explicitly wanted it to be built against GTK 3? Is that a bug?


More information about the webkit-gtk mailing list