[webkit-efl] Render issue

Daniel Robinson dgrobinson at dgrobinson.com
Mon Mar 4 15:59:49 PST 2013

I'm running WebKit EFL on a CentOS 6.3 machine.

When I run the MiniBrowser, I get an all white page.  I'm running on a
virtual machine and using Xvfb.  I am trying to load a well known site,
google.com.  When I do this with Firefox, I can use xwd to grab the root
plane of the display and Firefox is rendering the Google page.  When I run
the MiniBrowser, I know that it is accessing www.google.com because I see
the network traffic with tshark.  I can paint an arbitrary box in the
display with Xlib calls.  Using xwd, I can retrieve that.

Two thoughts:

1) Webkit is waiting for input of some kind.  Perhaps, but when I set the
DISPLAY variable to "localhost:14.0" or whatever, I see the window on my
workstation and by trying a number of things happen.  If I press the mouse
button at various points in the window, the URL in the URL window changes
to reflect new pages being loaded.

2) Some permission requirement is not being met.  I have built the
MiniBrowser in debug mode and when it quits, it lists the objects it has

Any help would be appreciated.

--dan robinson

daniel g. robinson
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-efl/attachments/20130304/88daf5dc/attachment.html>

More information about the webkit-efl mailing list