[webkit-efl] How about removing redundant "web" word from ewk_web_error_XXX APIs for webkit2

Dumez, Christophe christophe.dumez at intel.com
Wed Sep 26 22:48:24 PDT 2012


So it basically affects only 2 classes: ewk_web_error and ewk_web_resource,
If so, I think it is fine to rename them. This results in shorter names and
I don't think the new names are ambiguous.


On Thu, Sep 27, 2012 at 8:39 AM, JongSeok Yang <js45.yang at samsung.com>wrote:

> Dear webkit-efl developers,
> I'd like to discuss about "web" word for ewk APIs that is redundant word.
> As you know, "ewk" means "EFL WebKit" and ewk APIs don't have "web" word.
> For example, webview APIs for EFL port are ewk_view_XXX instead of
> ewk_web_view_XXX.
> And you can check the orignal WK APIs for ewk_web_error APIs like the
> below:
> WK_EXPORT WKStringRef WKErrorCopyWKErrorDomain();
> WK_EXPORT WKStringRef WKErrorCopyDomain(WKErrorRef error);
> WK_EXPORT int WKErrorGetErrorCode(WKErrorRef error);
> WK_EXPORT WKURLRef WKErrorCopyFailingURL(WKErrorRef error);
> WK_EXPORT WKStringRef WKErrorCopyLocalizedDescription(WKErrorRef error);
> So, I think that we should remove "web" word from ewk_web_error_XXX APIs
> for webkit2.
> I'll created new bug for this work. Could you let me know your opinion?
> BR,
> Jongseok Yang.
> _______________________________________________
> webkit-efl mailing list
> webkit-efl at lists.webkit.org
> http://lists.webkit.org/mailman/listinfo/webkit-efl

Christophe Dumez
Linux Software Engineer, PhD
Intel Finland Oy - Open Source Technology Center
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.webkit.org/pipermail/webkit-efl/attachments/20120927/5add32ae/attachment.html>

More information about the webkit-efl mailing list