[webkit-efl] How about removing redundant "web" word from ewk_web_error_XXX APIs for webkit2

JongSeok Yang js45.yang at samsung.com
Wed Sep 26 22:39:02 PDT 2012

Dear webkit-efl developers,

I'd like to discuss about "web" word for ewk APIs that is redundant word.

As you know, "ewk" means "EFL WebKit" and ewk APIs don't have "web" word.
For example, webview APIs for EFL port are ewk_view_XXX instead of ewk_web_view_XXX.
And you can check the orignal WK APIs for ewk_web_error APIs like the below:

WK_EXPORT WKStringRef WKErrorCopyWKErrorDomain();
WK_EXPORT WKStringRef WKErrorCopyDomain(WKErrorRef error);
WK_EXPORT int WKErrorGetErrorCode(WKErrorRef error);
WK_EXPORT WKURLRef WKErrorCopyFailingURL(WKErrorRef error);
WK_EXPORT WKStringRef WKErrorCopyLocalizedDescription(WKErrorRef error);

So, I think that we should remove "web" word from ewk_web_error_XXX APIs for webkit2.
I'll created new bug for this work. Could you let me know your opinion?

Jongseok Yang.

More information about the webkit-efl mailing list