[webkit-efl] Log macro support for EINA_LOG_DOM_XXX series

Jinwoo Song jinwoo7.song at samsung.com
Wed Sep 19 17:40:57 PDT 2012

I agree that WARN and INFO are more clear and consistent name. 
Then I'll create a bug to change the macro name in WebKit1 and WebKit2.

Thanks for feedback, Kenneth. :)


------- Original Message -------
Sender : Kenneth Rohde Christiansen<kenneth.christiansen at gmail.com>
Date : 2012-09-20 02:47 (GMT+09:00)
Title : Re: [webkit-efl] Log macro support for EINA_LOG_DOM_XXX series

So why are you using WRN and not WARN, INF and not INFO? The latter
seems better and more consistent


On Wed, Sep 19, 2012 at 7:02 AM, Jinwoo Song wrote:
> Dear webkit-efl developers,
> I'd like to notice you the newerly added log macros which wrap the EINA_LOG_DOM_XXX series.
> http://trac.webkit.org/changeset/128962
> #define CRITICAL(...) EINA_LOG_DOM_CRIT(_ewk_log_dom, __VA_ARGS__)
> #define ERR(...) EINA_LOG_DOM_ERR(_ewk_log_dom, __VA_ARGS__)
> #define WRN(...) EINA_LOG_DOM_WARN(_ewk_log_dom, __VA_ARGS__)
> #define INF(...) EINA_LOG_DOM_INFO(_ewk_log_dom, __VA_ARGS__)
> #define DBG(...) EINA_LOG_DOM_DBG(_ewk_log_dom, __VA_ARGS__)
> As you konw, the EINA_LOG_DOM_XXX logs a message on the speicified domain and format.
> In webkit2, 'ewebkit2' domain is registered in ewk_init(), so if you want to use the 'ewebkit2' domain for the error log,
> you can just use the simple log macros.
> Actually, the macro names came from the webkit1, but IMO, it seems to be better to align with EINA_LOG's names.
> If you have ideas or feedback, please let me know. :)
> Thanks,
> Jinwoo
> _______________________________________________
> webkit-efl mailing list
> webkit-efl at lists.webkit.org
> http://lists.webkit.org/mailman/listinfo/webkit-efl

Kenneth Rohde Christiansen
Senior Engineer, WebKit, Qt, EFL
Phone  +45 4093 0598 / E-mail kenneth at webkit.org


More information about the webkit-efl mailing list