[webkit-efl] Naming rules for setting APIs
christophe.dumez at intel.com
Wed Oct 10 04:13:16 PDT 2012
To my knowledge, the second one is more consistent with EFL naming style
(so I would vote for it):
*obj, Eina_Bool disabled)
On Wed, Oct 10, 2012 at 2:07 PM, Jinwoo Song <jinwoo7.song at samsung.com>wrote:
> I'm revisiting API names and documentation of WebKit2 EFL settings.
> Currently, there is no concrete rules for API naming, so the names are
> For example:
> Grzegorz suggested to use 'ewk_settings_enable_frame_flattening_set() with
> following rules and I also prefer this one.
> > 1) WK1 uses similar API, for example:
> > 2) Verb next to another verb (enabled_set) doesn't looks/sounds well.
> > 3) I'd rather prefer not using plural in API (enabled -> enable)
> > 4) The Spelling API bug 91854 proposes API syntax based on above
> suggestions (as during work on this there wasn't ewk2-settings yet). So we
> will have consistent API.
> FYI, GTK uses set_enable_frame_flattening() and Qt uses
> So I'd like to here the opinions for the naming rule and if there is no
> objections for the suggested rule, I'll adjust the APIs with this one.
> webkit-efl mailing list
> webkit-efl at lists.webkit.org
Linux Software Engineer, PhD
Intel Finland Oy - Open Source Technology Center
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the webkit-efl