[webkit-efl] About removing ewk_xxx_forward | backward_possible()

Leandro Pereira leandro at profusion.mobi
Mon Oct 10 05:17:37 PDT 2011


Gyuyoung

On 10/09/2011 10:31 PM, Gyuyoung Kim wrote:
> The APIs are
> ewk_frame_back_possible(), ewk_frame_forward_possible(). I think the APIs
> can be
> enough to replace by ewk_frame_navigate_possible().


I think they should remain. In the embedded, I think that code like:

   if (ewk_frame_back_possible(f))
      do_stuff_that_can_only_happen_if_going_back_is_possible();

Is more obvious than:

   if (ewk_frame_navigate_possible(f, -1))
      do_stuff_that_can_only_happen_if_going_back_is_possible();

Cheers,
     Leandro


More information about the webkit-efl mailing list