<html><head><meta http-equiv="Content-Type" content="text/html; charset=utf-8"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; line-break: after-white-space;" class="">On it<br class=""><div><br class=""><blockquote type="cite" class=""><div class="">On Dec 6, 2018, at 4:44 PM, Andy Estes <<a href="mailto:aestes@apple.com" class="">aestes@apple.com</a>> wrote:</div><br class="Apple-interchange-newline"><div class=""><meta http-equiv="Content-Type" content="text/html; charset=utf-8" class=""><div style="word-wrap: break-word; -webkit-nbsp-mode: space; line-break: after-white-space;" class=""><br class=""><div class=""><br class=""><blockquote type="cite" class=""><div class="">On Dec 6, 2018, at 4:37 PM, Chris Fleizach <<a href="mailto:cfleizach@apple.com" class="">cfleizach@apple.com</a>> wrote:</div><br class="Apple-interchange-newline"><div class=""><meta http-equiv="Content-Type" content="text/html; charset=utf-8" class=""><div style="word-wrap: break-word; -webkit-nbsp-mode: space; line-break: after-white-space;" class=""><br class=""><div class=""><br class=""><blockquote type="cite" class=""><div class="">On Dec 6, 2018, at 4:37 PM, Ryan Haddad <<a href="mailto:ryanhaddad@apple.com" class="">ryanhaddad@apple.com</a>> wrote:</div><br class="Apple-interchange-newline"><div class=""><meta http-equiv="Content-Type" content="text/html; charset=us-ascii" class=""><div style="word-wrap: break-word; -webkit-nbsp-mode: space; line-break: after-white-space;" class="">Chris,<div class=""><br class=""></div><div class=""><div class="">I'm assuming that this is in reference to the patch in <a href="https://bugs.webkit.org/show_bug.cgi?id=192373" class="">https://bugs.webkit.org/show_bug.cgi?id=192373</a>. My guess is that something about the changes to Source/WebKit/WebKit.xcodeproj/project.pbxproj is causing an issue with unified sources.</div><div class=""><br class=""></div><div class="">The commit-queue itself has been landing other patches without issue and the build isn't broken on trunk bots. CC'ing Tim in case he can help point out the issue.</div><div class=""><br class=""></div></div></div></div></blockquote><div class=""><br class=""></div><div class="">Yea must be. Any ideas why this wouldn’t build? I moved this .h/.mm to another folder (from Mac -> Cocoa) </div></div></div></div></blockquote><div class=""><br class=""></div>Looks like we need to forward-declare class WebKit::SafeBrowsingWarning in WebViewImpl.h. Can you try that in your patch and see if that fixes it?</div><div class=""><br class=""></div><div class="">Andy</div></div></div></blockquote></div><br class=""></body></html>