<html><head><meta http-equiv="Content-Type" content="text/html; charset=utf-8"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; line-break: after-white-space;" class="">When I want to use the public iOS SDK for WebKit on iOS, I refer to Dan’s blog post at <a href="https://webkit.org/blog/3457/building-webkit-for-ios-simulator/" class="">https://webkit.org/blog/3457/building-webkit-for-ios-simulator/</a><div class="">We have bots using this configuration and they’re working successfully at <a href="https://build.webkit.org/waterfall?category=iOS" class="">https://build.webkit.org/waterfall?category=iOS</a></div><div class="">Maybe you forgot to run configure-xcode-for-ios-development<br class=""><div><br class=""><blockquote type="cite" class=""><div class="">On Sep 27, 2017, at 7:10 AM, Frédéric WANG <<a href="mailto:fred.wang@free.fr" class="">fred.wang@free.fr</a>> wrote:</div><br class="Apple-interchange-newline"><div class=""><div class="">Hello,<br class=""><br class="">I've recently upgraded XCode and rebuilt Safari but when I try running<br class="">Safari on the simulator, I get the following errors:<br class=""><br class="">    Tools/Scripts/build-safari --ios-simulator --debug<br class="">    Tools/Scripts/run-safari --ios-simulator<br class="">    Quitting and launching iOS Simulator...<br class="">    Installing<br class="">/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator11.0.sdk/Applications/MobileSafari.app.<br class="">    An error was encountered processing the command<br class="">(domain=NSPOSIXErrorDomain, code=2):<br class="">    Failed to install the requested application<br class="">    An application bundle was not found at the provided path.<br class="">    Provide a valid path to the desired application bundle.<br class="">    Died at /Users/fred/WebKit/Tools/Scripts/webkitdirs.pm line 2546.<br class=""><br class="">I can not find any MobileSafari.app in my WebKitBuild directory nor in<br class="">the /Applications/ directory calculated by webkitdirs.pm ; trying to<br class="">hardcode a different path in webkitdirs.pm I instead obtain:<br class=""><br class="">    Quitting and launching iOS Simulator...<br class="">    Installing<br class="">/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/Library/CoreSimulator/Profiles/Runtimes/iOS.simruntime/Contents/Resources/RuntimeRoot/Applications/MobileSafari.app.<br class="">    An error was encountered processing the command<br class="">(domain=IXUserPresentableErrorDomain, code=2):<br class="">    This app was unable to be installed.<br class="">    Died at /Users/fred/WebKit/Tools/Scripts/webkitdirs.pm line 2546.<br class=""><br class="">Did anyone experience the same issue?<br class=""><br class="">-- <br class="">Frédéric Wang<br class=""><br class=""><br class="">_______________________________________________<br class="">webkit-dev mailing list<br class=""><a href="mailto:webkit-dev@lists.webkit.org" class="">webkit-dev@lists.webkit.org</a><br class="">https://lists.webkit.org/mailman/listinfo/webkit-dev<br class=""></div></div></blockquote></div><br class=""></div></body></html>