<html><head><meta http-equiv="Content-Type" content="text/html charset=utf-8"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; line-break: after-white-space;" class="">It would be nice if we could just get the CMake built WebKit working with run-safari and run-webkit-tests.  That’s something I’ve been meaning to do for a while but haven’t gotten around to it.  Something is wrong with the xpc service locations and plists, but I think everything else should be ok since run-minibrowser works fine with WebKit1.  Let me know if you want to help out with this approach and I’ll give you more details<br class=""><div><br class=""><blockquote type="cite" class=""><div class="">On May 8, 2017, at 6:39 AM, Ben Kelly <<a href="mailto:ben@wanderview.com" class="">ben@wanderview.com</a>> wrote:</div><br class="Apple-interchange-newline"><div class=""><div dir="ltr" class="">On Mon, May 8, 2017 at 12:32 AM, youenn fablet <span dir="ltr" class=""><<a href="mailto:youennf@gmail.com" target="_blank" class="">youennf@gmail.com</a>></span> wrote:<br class=""><div class="gmail_extra"><div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr" class="">I had this setup working a year or so ago. I was using the regular Mac "make" build.<div class=""><br class=""><div class="gmail_quote"><span class=""><div dir="ltr" class="">Le dim. 7 mai 2017 à 19:28, Ben Kelly <<a href="mailto:ben@wanderview.com" target="_blank" class="">ben@wanderview.com</a>> a écrit :<br class=""></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr" class=""><div class=""><div class=""><div class=""><div class=""><div class=""><div class=""><div class=""><div class="">Hi all,<br class=""><br class=""></div>Does anyone have ccache (or an equivalent) working with local webkit builds on mac?  I've spent the last couple of days trying to figure out, but have not had much luck.<br class=""><br class=""></div>I've installed ccache via homebrew and its in my path.<br class=""></div></div></div></div></div></div></div></blockquote><div class=""><br class=""></div></span><div class="">Did the same. I had to ensure clang used by Xcode was the ccache proxy.</div><div class="">Don't remember whether just setting CC/CXX in the command line works.</div><div class="">When running make, you can see which clang is used.</div><div class="">Maybe setting CC/CXX in Source/WebCore/Configurations/<wbr class="">Base.xcconfig would do the trick (for WebCore).<br class=""></div></div></div></div></blockquote><div class=""><br class=""></div><div class="">I guess I'm hesitant to fiddle with Base.xcconfig because I don't want to accidentally include those changes in patches, etc.</div><div class=""><br class=""></div><div class="">What is the syntax for overriding CC/CXX on the command line with build-webkit?  (Or for the make build, although its unclear how to configure that.)</div><div class=""><br class=""></div><div class="">I guess I was also hoping there was some way to specify a 'user-override.xcconfig' that the webkit build would try to pull-in automatically where this stuff could be set.</div><div class=""><br class=""></div><div class="">Thanks.</div><div class=""><br class=""></div><div class="">Ben<br class=""></div></div></div></div>
_______________________________________________<br class="">webkit-dev mailing list<br class=""><a href="mailto:webkit-dev@lists.webkit.org" class="">webkit-dev@lists.webkit.org</a><br class="">https://lists.webkit.org/mailman/listinfo/webkit-dev<br class=""></div></blockquote></div><br class=""></body></html>