<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=Windows-1252">
</head>
<body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;">
<br>
<div>
<div>On Mar 26, 2014, at 16:40 , Bem Jones-Bey &lt;<a href="mailto:bjonesbe@adobe.com">bjonesbe@adobe.com</a>&gt; wrote:</div>
<br class="Apple-interchange-newline">
<blockquote type="cite">
<div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;">
On Mar 24, 2014, at 15:54 , Dirk Pranke &lt;<a href="mailto:dpranke@chromium.org">dpranke@chromium.org</a>&gt; wrote:<br>
<div><br class="Apple-interchange-newline">
<blockquote type="cite">
<div dir="ltr"><br>
<div class="gmail_extra"><br>
<br>
<div class="gmail_quote">On Mon, Mar 24, 2014 at 3:32 PM, Bem Jones-Bey <span dir="ltr">
&lt;<a href="mailto:bjonesbe@adobe.com" target="_blank">bjonesbe@adobe.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div style="word-wrap:break-word">
<div class=""><br>
<div>
<div>On Mar 24, 2014, at 14:54 , Dirk Pranke &lt;<a href="mailto:dpranke@chromium.org" target="_blank">dpranke@chromium.org</a>&gt; wrote:</div>
<br>
<blockquote type="cite">
<div dir="ltr"><br>
<div class="gmail_extra"><br>
<br>
<div class="gmail_quote">On Sun, Mar 23, 2014 at 12:52 PM, Benjamin Poulain <span dir="ltr">
&lt;<a href="mailto:benjamin@webkit.org" target="_blank">benjamin@webkit.org</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Same here :(
<div><br>
<br>
On 3/23/14, 12:15 PM, Darin Adler wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
When I use run-webkit-tests to run the entire test suite, on a debug build of TOT WebKit, on Mavericks, Iím having the following problems:<br>
<br>
- Towards the end of the run, the tests run slowly, over a second per test on my 3.5GHz i7 iMac with tons of memory, which is about 10X too slow I think. The sample shows the vast majority of the time is spent in JavaScript garbage collection. This is running
 mostly the svg/custom tests.<br>
</blockquote>
</div>
Yep. The time from 31k to 33k is a long as from 0 to 31k :(
<div><br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
- Towards the end of the run, instead of the 8 parallel copies of DumpRenderTree, only 1 copy of DumpRenderTree seems to run. This is running mostly the svg/custom tests.<br>
</blockquote>
</div>
I think the problem is we can only run DumpRenderTree in parallel on different folders. Toward the end, everything left is one or two slow folders.
<div><br>
</div>
</blockquote>
<div><br>
</div>
<div>The problem is partially that the sharding is folder-at-a-time, partially that the svg folder is big and slow, and partially that &quot;svg&quot; comes near the end of the alphabet (i.e., we don't start the big slow directory until close to the end of run, so there
 ends up being one big long pole).</div>
<div><br>
</div>
<div>At some point we added code to run-webkit-tests to have a list of &quot;slow&quot; directories that got started towards the beginning. I don't remember if we did that before or after the Blink fork, but it would be easy to port it over from Blink if it was after.</div>
</div>
</div>
</div>
</blockquote>
<br>
</div>
</div>
<div>I'm pretty sure this was after the Blink fork. I did a quick look through the history, and I found this:</div>
<div><br>
</div>
<div>
<div><a href="http://src.chromium.org/viewvc/blink?revision=152697&amp;view=revision" target="_blank">http://src.chromium.org/viewvc/blink?revision=152697&amp;view=revision</a></div>
<div><br>
</div>
</div>
<div>Is that the correct change? If it will make tests run faster in WebKit land as well, I'm more than happy to port it myself. :-)</div>
<span class="HOEnZb"><font color="#888888">
<div><br>
</div>
</font></span></div>
</blockquote>
<div><br>
</div>
<div>Yup, that's the one. Obviously the whole &quot;virtual test suite&quot; thing is less relevant, but you can use it for any directory you want.</div>
</div>
</div>
</div>
</blockquote>
<br>
</div>
<div>Well, I tried that patch, replacing &quot;virtual&quot; with &quot;svg&quot;, and it doesn't seem to have any effect on the speed of the run for me. But I'm also not 100% sure that I am seeing the slowness issue that others are reporting. (I also get 18 copies of DRT, not
 8, so....)</div>
</div>
</blockquote>
<br>
</div>
<div>In case it matters, I ran the tests with WTR, and I see the issue; however, it's not svg tests for me: it's http and ietestcenter tests, and a couple of others. So it doesn't look like it's related to a single batch of tests.</div>
<div><br>
</div>
<div>- Bem</div>
<br>
</body>
</html>