<div dir="ltr">Hm... it appears that I was wrong about this.  It appears that this is the intended feature in gcc:<div><a href="http://gcc.gnu.org/bugzilla/show_bug.cgi?id=28236" target="_blank">http://gcc.gnu.org/bugzilla/show_bug.cgi?id=28236</a><br>


</div><div><br></div><div>Regardless, I don&#39;t think we should have this warning enabled. We&#39;re generating some unused code everywhere :(</div><div><br></div><div class="gmail_extra"><div>- R. Niwa</div>
<br><br><div class="gmail_quote">On Thu, Sep 12, 2013 at 5:15 PM, Allan Sandfeld Jensen <span dir="ltr">&lt;<a href="mailto:kde@carewolf.com" target="_blank">kde@carewolf.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">


<div>On Friday 13 September 2013, Benjamin Poulain wrote:<br>
</div><div>&gt; On 9/12/13 4:48 PM, Ryosuke Niwa wrote:<br>
&gt; &gt; On Thu, Sep 12, 2013 at 4:45 PM, Allan Sandfeld Jensen<br>
&gt; &gt;<br>
</div><div>&gt; &gt; &lt;<a href="mailto:kde@carewolf.com" target="_blank">kde@carewolf.com</a> &lt;mailto:<a href="mailto:kde@carewolf.com" target="_blank">kde@carewolf.com</a>&gt;&gt; wrote:<br>
&gt; &gt;     Don&#39;t worry we are still here, just in fewer numbers, and with<br>
&gt; &gt;     fewer things to<br>
&gt; &gt;     support.<br>
&gt; &gt;<br>
&gt; &gt;     I would prefer to keep the warning, it is quite useful at times,<br>
&gt; &gt;     and when it<br>
&gt; &gt;     isn&#39;t you just add a default case with an ASSERT_NOT_REACHED()<br>
&gt; &gt;<br>
</div><div>&gt; &gt; And that&#39;s an added maintenance cost everyone has to pay.<br>
&gt; &gt;<br>
&gt; &gt; Given that other ports such as Mac &amp; GTK+ have this warning enabled<br>
&gt; &gt; and we have reliable EWS bots, I don&#39;t see why we want to keep this<br>
&gt; &gt; warning on ports that use old versions of gcc that force us to add<br>
&gt; &gt; useless code.<br>
&gt;<br>
&gt; I agree with you on this, I had the problem several times.<br>
&gt;<br>
&gt; I think the best would be to update the Qt bots. If that cannot be done,<br>
&gt; it would be best to disable the warning until the bots can be upgraded.<br>
&gt;<br>
</div>Do we know what GCC versions are bad, or at least at what point they become<br>
good enough on this warning? (we tend to get more warnings not fewer with gcc<br>
4.8).<br>
<span><font color="#888888"><br>
`Allan<br>
</font></span></blockquote></div><br></div></div>