<br><br><div class="gmail_quote">On Fri, Jul 13, 2012 at 10:59 AM, Eric Seidel <span dir="ltr">&lt;<a href="mailto:eric@webkit.org" target="_blank">eric@webkit.org</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
&lt;bikeshedding&gt;<br>
<br>
Just like we don&#39;t call the class DOMDocument, there is no need to add<br>
the CSS prefix where there aren&#39;t collisions (IMO).<br>
<br>
I do think we should drop the &quot;WebKit&quot; prefix from all classes, and<br>
use InterfaceName= the .idl to map from &quot;InternalName&quot; to<br>
&quot;WebKitExternalName&quot;.<br>
<br></blockquote><div><br></div><div>^^^ yes, please :-)</div><div><br></div><div>/me crawls back into his hole.</div><div><br></div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">

<a href="http://trac.webkit.org/wiki/WebKitIDL#InterfaceName" target="_blank">http://trac.webkit.org/wiki/WebKitIDL#InterfaceName</a><br>
<br>
&lt;/bikeshedding&gt;<br>
<div class="HOEnZb"><div class="h5"><br>
On Fri, Jul 13, 2012 at 7:17 AM, Andrei Bucur &lt;<a href="mailto:abucur@adobe.com">abucur@adobe.com</a>&gt; wrote:<br>
&gt; CSSRegion is it then! I&#39;ll also make a patch to rename WebKitNamedFlow<br>
&gt; into CSSNamedFlow.<br>
&gt;<br>
&gt; Thx!<br>
&gt; Andrei.<br>
&gt;<br>
&gt; On 7/12/12 10:37 PM, &quot;Alexis Menard&quot; &lt;<a href="mailto:alexis.menard@openbossa.org">alexis.menard@openbossa.org</a>&gt; wrote:<br>
&gt;<br>
&gt;&gt;So far in the css/ directory we tried to renamed slowly classes so that :<br>
&gt;&gt;<br>
&gt;&gt;CSS* prefixed classes are the implementation of CSSOM<br>
&gt;&gt;&quot;whatevername&quot; is for internal classes. For example we renamed<br>
&gt;&gt;CSSStyleApplyProperty class to StyleBuilder because it&#39;s internal.<br>
&gt;&gt;<br>
&gt;&gt;Hope that helps.<br>
&gt;&gt;<br>
&gt;&gt;On Thu, Jul 12, 2012 at 2:52 PM, Simon Fraser &lt;<a href="mailto:simon.fraser@apple.com">simon.fraser@apple.com</a>&gt;<br>
&gt;&gt;wrote:<br>
&gt;&gt;&gt; I&#39;d prefer we keep &quot;Region&quot; for the low-level graphics primitive Region<br>
&gt;&gt;&gt; (just like Path), and use something prefixed for the higher-level layout<br>
&gt;&gt;&gt; concept.<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; Simon<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; On Jul 12, 2012, at 10:26 AM, Dana Jansens wrote:<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; On Thu, Jul 12, 2012 at 1:25 PM, Ryosuke Niwa &lt;<a href="mailto:rniwa@webkit.org">rniwa@webkit.org</a>&gt; wrote:<br>
&gt;&gt;&gt;&gt;<br>
&gt;&gt;&gt;&gt; I&#39;d vote for CSSRegion or CSSOMRegion for the class you&#39;re adding but<br>
&gt;&gt;&gt;&gt;I&#39;ll<br>
&gt;&gt;&gt;&gt; also suggest we rename the existing Region class now that the term<br>
&gt;&gt;&gt;&gt;&quot;region&quot;<br>
&gt;&gt;&gt;&gt; has a specific semantic in CSS. Maybe LayoutRegion or ScreenRegion?<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; IntRegion? It seems closer to an IntRect than a LayoutRect.<br>
&gt;&gt;&gt;&gt;<br>
&gt;&gt;&gt;&gt; - Ryosuke<br>
&gt;&gt;&gt;&gt;<br>
&gt;&gt;&gt;&gt; On Jul 12, 2012 10:13 AM, &quot;Eric Seidel&quot; &lt;<a href="mailto:eric@webkit.org">eric@webkit.org</a>&gt; wrote:<br>
&gt;&gt;&gt;&gt;&gt;<br>
&gt;&gt;&gt;&gt;&gt; I would go with CSSRegion, and stick it in the css/ folder.  Much of<br>
&gt;&gt;&gt;&gt;&gt; the CSS folder is our implementation of the CSS Object Model (CSSOM).<br>
&gt;&gt;&gt;&gt;&gt; At some point it might make sense to pull all the classes which<br>
&gt;&gt;&gt;&gt;&gt; implement the CSSOM out of css/ into a new cssom/ similar to dom/, but<br>
&gt;&gt;&gt;&gt;&gt; that&#39;s a later discussion.<br>
&gt;&gt;&gt;&gt;&gt;<br>
&gt;&gt;&gt;&gt;&gt; -eric<br>
&gt;&gt;&gt;&gt;&gt;<br>
&gt;&gt;&gt;&gt;&gt; On Thu, Jul 12, 2012 at 10:03 AM, Andrei Bucur &lt;<a href="mailto:abucur@adobe.com">abucur@adobe.com</a>&gt;<br>
&gt;&gt;&gt;&gt;&gt;wrote:<br>
&gt;&gt;&gt;&gt;&gt; &gt; From my knowledge the &quot;CSS&quot; prefix is reserved for the CSS engine<br>
&gt;&gt;&gt;&gt;&gt; &gt; classes in<br>
&gt;&gt;&gt;&gt;&gt; &gt; WebKit. Prefixing the Region class with &quot;CSS&quot; could prove confusing.<br>
&gt;&gt;&gt;&gt;&gt; &gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt; Regards,<br>
&gt;&gt;&gt;&gt;&gt; &gt; Andrei.<br>
&gt;&gt;&gt;&gt;&gt; &gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt; From: Alan Stearns &lt;<a href="mailto:stearns@adobe.com">stearns@adobe.com</a>&gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt; Date: Thursday, July 12, 2012 7:39 PM<br>
&gt;&gt;&gt;&gt;&gt; &gt; To: Adam Barth &lt;<a href="mailto:abarth@webkit.org">abarth@webkit.org</a>&gt;, Andrei Bucur &lt;<a href="mailto:abucur@adobe.com">abucur@adobe.com</a>&gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt; Cc: &quot;<a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a>&quot; &lt;<a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a>&gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt; Subject: Re: [webkit-dev] Web APIs and class name collisions<br>
&gt;&gt;&gt;&gt;&gt; &gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt; The spec itself consistently and deliberately calls them &quot;CSS<br>
&gt;&gt;&gt;&gt;&gt;Regions,&quot;<br>
&gt;&gt;&gt;&gt;&gt; &gt; so a<br>
&gt;&gt;&gt;&gt;&gt; &gt; CSS prefix could be appropriate.<br>
&gt;&gt;&gt;&gt;&gt; &gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt; Thanks,<br>
&gt;&gt;&gt;&gt;&gt; &gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt; Alan<br>
&gt;&gt;&gt;&gt;&gt; &gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt; From: Adam Barth &lt;<a href="mailto:abarth@webkit.org">abarth@webkit.org</a>&gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt; To: Andrei Bucur &lt;<a href="mailto:abucur@adobe.com">abucur@adobe.com</a>&gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt; Cc: &quot;<a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a>&quot; &lt;<a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a>&gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt; Subject: Re: [webkit-dev] Web APIs and class name collisions<br>
&gt;&gt;&gt;&gt;&gt; &gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt; One common thing we do is prefix &quot;DOM&quot; to DOM-level concepts.  For<br>
&gt;&gt;&gt;&gt;&gt; &gt; example,<br>
&gt;&gt;&gt;&gt;&gt; &gt; DOMWindow and DOMFileSystem.  I&#39;m not sure if we have an established<br>
&gt;&gt;&gt;&gt;&gt; &gt; convention for CSS-level concepts.<br>
&gt;&gt;&gt;&gt;&gt; &gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt; Adam<br>
&gt;&gt;&gt;&gt;&gt; &gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt; On Thu, Jul 12, 2012 at 9:18 AM, Andrei Bucur &lt;<a href="mailto:abucur@adobe.com">abucur@adobe.com</a>&gt;<br>
&gt;&gt;&gt;&gt;&gt;wrote:<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt; Hello Webkittens!<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt; While implementing the Region interface (<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt; <a href="http://dev.w3.org/csswg/css3-regions/#the-region-interface" target="_blank">http://dev.w3.org/csswg/css3-regions/#the-region-interface</a> ) I&#39;ve<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt; noticed<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt; that the name &quot;Region&quot; is already taken by a class in<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt; platform/graphics. I&#39;d<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt; like to know what&#39;s the best approach in these kind of situations:<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt; Rename the existing WebCore class to something else and use the<br>
&gt;&gt;&gt;&gt;&gt;name<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt; &quot;Region&quot; for the Web API so there&#39;s parity between the<br>
&gt;&gt;&gt;&gt;&gt;implementation<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt; and<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt; the spec<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt; Somehow prefix the Web API implementation class name?<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt; As the Web APIs expand I suppose this situation may occur again in<br>
&gt;&gt;&gt;&gt;&gt;the<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt; future and I suppose there should be a rule describing what&#39;s the<br>
&gt;&gt;&gt;&gt;&gt;best<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt; approach to take.<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt; Thanks!<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt; Andrei.<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt; _______________________________________________<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt; webkit-dev mailing list<br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt; <a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a><br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt; <a href="http://lists.webkit.org/mailman/listinfo/webkit-dev" target="_blank">http://lists.webkit.org/mailman/listinfo/webkit-dev</a><br>
&gt;&gt;&gt;&gt;&gt; &gt;&gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt;<br>
&gt;&gt;&gt;&gt;&gt; &gt; _______________________________________________<br>
&gt;&gt;&gt;&gt;&gt; &gt; webkit-dev mailing list<br>
&gt;&gt;&gt;&gt;&gt; &gt; <a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a><br>
&gt;&gt;&gt;&gt;&gt; &gt; <a href="http://lists.webkit.org/mailman/listinfo/webkit-dev" target="_blank">http://lists.webkit.org/mailman/listinfo/webkit-dev</a><br>
&gt;&gt;&gt;&gt;&gt; &gt;<br>
&gt;&gt;&gt;&gt;&gt; _______________________________________________<br>
&gt;&gt;&gt;&gt;&gt; webkit-dev mailing list<br>
&gt;&gt;&gt;&gt;&gt; <a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a><br>
&gt;&gt;&gt;&gt;&gt; <a href="http://lists.webkit.org/mailman/listinfo/webkit-dev" target="_blank">http://lists.webkit.org/mailman/listinfo/webkit-dev</a><br>
&gt;&gt;&gt;&gt;<br>
&gt;&gt;&gt;&gt;<br>
&gt;&gt;&gt;&gt; _______________________________________________<br>
&gt;&gt;&gt;&gt; webkit-dev mailing list<br>
&gt;&gt;&gt;&gt; <a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a><br>
&gt;&gt;&gt;&gt; <a href="http://lists.webkit.org/mailman/listinfo/webkit-dev" target="_blank">http://lists.webkit.org/mailman/listinfo/webkit-dev</a><br>
&gt;&gt;&gt;&gt;<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; _______________________________________________<br>
&gt;&gt;&gt; webkit-dev mailing list<br>
&gt;&gt;&gt; <a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a><br>
&gt;&gt;&gt; <a href="http://lists.webkit.org/mailman/listinfo/webkit-dev" target="_blank">http://lists.webkit.org/mailman/listinfo/webkit-dev</a><br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt;<br>
&gt;&gt;&gt; _______________________________________________<br>
&gt;&gt;&gt; webkit-dev mailing list<br>
&gt;&gt;&gt; <a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a><br>
&gt;&gt;&gt; <a href="http://lists.webkit.org/mailman/listinfo/webkit-dev" target="_blank">http://lists.webkit.org/mailman/listinfo/webkit-dev</a><br>
&gt;&gt;&gt;<br>
&gt;&gt;<br>
&gt;&gt;<br>
&gt;&gt;<br>
&gt;&gt;--<br>
&gt;&gt;Alexis Menard (darktears)<br>
&gt;&gt;Software Engineer<br>
&gt;&gt;openBossa @ INdT - Instituto Nokia de Tecnologia<br>
&gt;&gt;_______________________________________________<br>
&gt;&gt;webkit-dev mailing list<br>
&gt;&gt;<a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a><br>
&gt;&gt;<a href="http://lists.webkit.org/mailman/listinfo/webkit-dev" target="_blank">http://lists.webkit.org/mailman/listinfo/webkit-dev</a><br>
&gt;<br>
_______________________________________________<br>
webkit-dev mailing list<br>
<a href="mailto:webkit-dev@lists.webkit.org">webkit-dev@lists.webkit.org</a><br>
<a href="http://lists.webkit.org/mailman/listinfo/webkit-dev" target="_blank">http://lists.webkit.org/mailman/listinfo/webkit-dev</a><br>
</div></div></blockquote></div><br>