<html><head><meta http-equiv="Content-Type" content="text/html charset=windows-1252"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; "><br><div><div>On May 31, 2012, at 3:11 PM, Ryosuke Niwa <<a href="mailto:rniwa@webkit.org">rniwa@webkit.org</a>> wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite"><div class="gmail_quote">On Thu, May 31, 2012 at 11:56 AM, Darin Adler <span dir="ltr"><<a href="mailto:darin@apple.com" target="_blank">darin@apple.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">

I am thinking we should rename layoutTestController to testController. Or if you donít like that name, maybe testHarness or some even better name.<br></blockquote><div><br></div><div>"testController" seems like a misnomer since it doesn't really control the test itself. I would prefer testRunnerController or simply testRunner since it's quite self-evident that methods on testRunner would act on the test runner itself.</div>

<div><br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
We could expose the object under the new name and the old one, and then over time convert all the tests to the new name, then get rid of the old one.<br></blockquote><div><br></div><div>That sounds like a good idea.</div>

<div><br></div><div>Can we also rename LayoutTests to RegressionTests? I know Dave (Hyatt) suggested to cleanup the render tree dump format to get rid of all hacks and tweaks we've added over years, and my preference is to combine all these efforts and put new types of tests in trunk/RegressionTests. We'll move tests from LayoutTests to RegressionTests as we convert. We'll get rid of LayoutTests directory once all tests have been converted to use testRunner and new render tree dump format.</div>

</div></blockquote><br></div><div>I don't think renaming the directory should be tired to changing the output format. In particular, it would be confusing to have both RegressionTests and LayoutTests exist at the same time for an extended period. I don't think it has worked out very well to have both WebCore/platform/ and Platform/ exist at the same time, for instance. There are other ways to track an incremental conversion effort.</div><div><br></div><div>Regards,</div><div>Maciej</div><div><br></div><br></body></html>