<br><br><div class="gmail_quote">On Wed, Nov 30, 2011 at 5:42 PM, Alan Stearns <span dir="ltr"><<a href="mailto:stearns@adobe.com">stearns@adobe.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">





<div>
<font face="Verdana, Helvetica, Arial"><span style="font-size:11pt">David,<br>
<br>
  This is a bug where I accidentally turned on a pixel result, then needed to remove the .pngs when I fixed the problem:<br>
<br>
<a href="https://bugs.webkit.org/show_bug.cgi?id=73343" target="_blank">https://bugs.webkit.org/show_bug.cgi?id=73343</a><br>
<br>
  The patch had two lines like this:<br>
<br>
Binary files a/LayoutTests/platform/efl/fast/regions/no-split-line-box-expected.png and /dev/null differ<br>
<br>
  Which resulted in this output from style-queue:<br>
<br>
Failed to run "[u'/mnt/git/webkit-style-queue/Tools/Scripts/svn-apply', u'--force']" exit_code: 9<br>
<br>
Error: the Git diff contains a binary file without the binary data in line: "Binary files a/LayoutTests/platform/efl/fast/regions/no-split-line-box-expected.png and /dev/null differ".  Be sure to use the --binary flag when invoking "git diff" with diffs containing binary files. at /mnt/git/webkit-style-queue/Tools/Scripts/VCSUtils.pm line 667, <ARGV> line 45.<br>

</span></font></div></blockquote><div><br></div><div>Ah, your issue is with how the patch is applied and that it fails and it causes the style bot to fail.</div><div><br></div><div>This seems like a general EWS issue. It would be good to run the builds run for your patch as well even though you didn't have the binary in there.</div>

<div><br></div><div><br></div><div>dave</div></div>